Bug report #20283

Crash when exiting program [proj_lpz_dist]

Added by Jerry Brand about 1 year ago. Updated 9 months ago.

Status:Reopened
Priority:Normal
Assignee:-
Category:Actions
Affected QGIS version:3.4.0 Regression?:No
Operating System:Windows 10 Professional Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28104

Description

User Feedback

Just closing the program

Report Details

Crash ID: a3eb9e008e3031d98e71767c90264528b8c82c02

Stack Trace

proj_lpz_dist :
proj_lpz_dist :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::~QgsCoordinateTransform :
QgsFirstRunDialog::trUtf8 :
QObjectPrivate::deleteChildren :
QWidget::~QWidget :
CPLStringList::operator char const * __ptr64 const * __ptr64 :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.0-Madeira
QGIS code revision: 4a4b62ed19
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

zippee.qgs (2.74 KB) Phil Wyatt, 2019-01-24 12:10 PM


Related issues

Related to QGIS Application - Bug report #21912: QGIS Crashed Open 2019-04-23
Duplicates QGIS Application - Bug report #20326: Crash when Quit QGIS Closed 2018-11-02
Duplicated by QGIS Application - Bug report #20275: QGIS Crash When Closing Application Closed 2018-10-30
Duplicated by QGIS Application - Bug report #20314: QGIS 3.4 crashed when exiting immediately after saving Closed 2018-11-01
Duplicated by QGIS Application - Bug report #20482: QGIS crash Closed 2018-11-13
Duplicated by QGIS Application - Bug report #20511: QGIS 3.4.1 crashes when closing Closed 2018-11-15
Duplicated by QGIS Application - Bug report #20506: Crash on exit qgis 3.4.1 Closed 2018-11-15
Duplicated by QGIS Application - Bug report #20501: Crash on closing the application. Closed 2018-11-15
Duplicated by QGIS Application - Bug report #20520: Crash Closed 2018-11-16
Duplicated by QGIS Application - Bug report #20526: QGIS crash Closed 2018-11-17
Duplicated by QGIS Application - Bug report #20589: Crash before closing Closed 2018-11-22
Duplicated by QGIS Application - Bug report #20613: QGIS crash when closing the software Closed 2018-11-23
Duplicated by QGIS Application - Bug report #20618: QGis 3.4 reproducible crash while in idle state Closed 2018-11-24
Duplicated by QGIS Application - Bug report #20644: Crash on exit qgis 3.4.2 Closed 2018-11-27
Duplicated by QGIS Application - Bug report #20652: QGIS 3.4.1 crashing Closed 2018-11-28
Duplicated by QGIS Application - Bug report #20675: QGIS crashes after successful saving the project and tryi... Closed 2018-11-29
Duplicated by QGIS Application - Bug report #20677: Very often crashes. Quite 2 each day Closed 2018-11-29
Duplicated by QGIS Application - Bug report #20679: QGIS Crashed when closing project without saving Closed 2018-11-29
Duplicated by QGIS Application - Bug report #20729: QGIS 3.4.2 crashes on exit Closed 2018-12-05
Duplicated by QGIS Application - Bug report #20697: QGIS 3.4.2 crashes on exit Closed 2018-12-03
Duplicated by QGIS Application - Bug report #20782: crash when quit Qgis Closed 2018-12-11
Duplicated by QGIS Application - Bug report #20806: QGIS 3.4.2 crush on exit Closed 2018-12-13
Duplicated by QGIS Application - Bug report #20823: QGIS crashing on exit Closed 2018-12-17
Duplicated by QGIS Application - Bug report #20881: QGIS crash when quitting Closed 2018-12-25
Duplicated by QGIS Application - Bug report #20858: Regular crashes each day Closed 2018-12-20
Duplicated by QGIS Application - Bug report #20900: Crashed while trying to save the project Closed 2019-01-01
Duplicated by QGIS Application - Bug report #20901: Crashed when exiting a project Closed 2019-01-01
Duplicated by QGIS Application - Bug report #20926: Crashed while closing without saving Closed 2019-01-06
Duplicated by QGIS Application - Bug report #20923: QGIS crash Closed 2019-01-04
Duplicated by QGIS Application - Bug report #20959: QGIS crash when saving and closing a project. Closed 2019-01-10
Duplicated by QGIS Application - Bug report #20967: Crash Closed 2019-01-10
Duplicated by QGIS Application - Bug report #20970: QGIS Crashed Windows when close qis Closed 2019-01-11
Duplicated by QGIS Application - Bug report #20982: QGIS crash when I close it Closed 2019-01-12
Duplicated by QGIS Application - Bug report #20816: Crash by closing Qgis 3.4.2 Closed 2018-12-14
Duplicated by QGIS Application - Bug report #20851: 3.4.2 Crashed on Exit Closed 2018-12-20
Duplicated by QGIS Application - Bug report #21000: QGIS crash error on exit Closed 2019-01-15
Duplicated by QGIS Application - Bug report #21030: Crash on exit - multiple times Closed 2019-01-18
Duplicated by QGIS Application - Bug report #21054: Crash on closing project Closed 2019-01-21
Duplicated by QGIS Application - Bug report #20939: saving the project Closed 2019-01-08
Duplicated by QGIS Application - Bug report #21110: Frequent crash when saving project Closed 2019-01-26
Duplicated by QGIS Application - Bug report #21133: multiple crashes Closed 2019-01-30
Duplicated by QGIS Application - Bug report #21131: Crash Closed 2019-01-30
Duplicated by QGIS Application - Bug report #21149: 3.4.3-Madeira Crashing on closing Closed 2019-02-01
Duplicated by QGIS Application - Bug report #21156: Trying to add map themes crashes QGIS Closed 2019-02-03
Duplicated by QGIS Application - Bug report #21155: Crashes on Exit Closed 2019-02-03
Duplicated by QGIS Application - Bug report #21186: QGis crashed on close Closed 2019-02-06
Duplicated by QGIS Application - Bug report #21187: QGIS Crashed Closed 2019-02-06
Duplicated by QGIS Application - Bug report #21219: Programme crashing Closed 2019-02-09
Duplicated by QGIS Application - Bug report #21208: Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63 Closed 2019-02-08
Duplicated by QGIS Application - Bug report #21223: QGis 3.4 crashed when I want to quit Closed 2019-02-11
Duplicated by QGIS Application - Bug report #21248: Program keeps crashing on closing Closed 2019-02-12
Duplicated by QGIS Application - Bug report #21255: Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63 Closed 2019-02-13
Duplicated by QGIS Application - Bug report #21258: Crash on closing Closed 2019-02-13
Duplicated by QGIS Application - Bug report #21345: QGIS crashes Closed 2019-02-22
Duplicated by QGIS Application - Bug report #21334: QGIS crashes everytime I try to exit the program. Closed 2019-02-21
Duplicated by QGIS Application - Bug report #21276: crash when quitting Closed 2019-02-14
Duplicated by QGIS Application - Bug report #21152: QGIS Crash on exit Closed 2019-02-02
Duplicated by QGIS Application - Bug report #21384: QGIS 3.6 crashes upon exiting Closed 2019-02-26
Duplicated by QGIS Application - Bug report #21431: Crashed when shutting down Closed 2019-02-28
Duplicated by QGIS Application - Bug report #21483: QGIS Crashed Closed 2019-03-05
Duplicated by QGIS Application - Bug report #21512: QGIS Crashed- Crash ID: 62f1fcd2045780cb9f127836e6b579b86... Closed 2019-03-07
Duplicated by QGIS Application - Bug report #21612: System crashes when exiting application Closed 2019-03-18
Duplicated by QGIS Application - Bug report #21550: Crashing every time I close program Closed 2019-03-11
Duplicated by QGIS Application - Bug report #21667: Crash in 3.4.6 Closed 2019-03-25
Duplicated by QGIS Application - Bug report #21671: Crash when closing qGis-Desktop-Application Closed 2019-03-25
Duplicated by QGIS Application - Bug report #21682: Crash Closed 2019-03-27
Duplicated by QGIS Application - Bug report #21689: QGIS Crash on Exit Closed 2019-03-28
Duplicated by QGIS Application - Bug report #21750: crash on exit Closed 2019-04-03
Duplicated by QGIS Application - Bug report #21790: QGIS 3.4.4 crashes on Save when more than one copy running Closed 2019-04-08
Duplicated by QGIS Application - Bug report #21827: QGIS Crashed on exit Closed 2019-04-10
Duplicated by QGIS Application - Bug report #21842: Crashed while trying to close Closed 2019-04-12
Duplicated by QGIS Application - Bug report #21881: QGIS crashes on closing Closed 2019-04-18
Duplicated by QGIS Application - Bug report #21903: qgis-ltr-bin.exe not respond Closed 2019-04-22
Duplicated by QGIS Application - Bug report #21915: keeps crashing at the end of each session Closed 2019-04-24
Duplicated by QGIS Application - Bug report #21916: Crash on exit from qgis 3.0.2-3.6.2 Closed 2019-04-24
Duplicated by QGIS Application - Bug report #21937: Crash during shutdown Closed 2019-04-26
Duplicated by QGIS Application - Bug report #21943: QGIS Crash Closed 2019-04-26
Duplicated by QGIS Application - Bug report #21946: Crash after activating dark theme Closed 2019-04-26
Duplicated by QGIS Application - Bug report #21929: QGIS crash on closing Closed 2019-04-25
Duplicated by QGIS Application - Bug report #21998: Error to close the project Closed 2019-05-05
Duplicated by QGIS Application - Bug report #22042: Unexpected Crash on Exit Closed 2019-05-09
Duplicated by QGIS Application - Bug report #22080: crash when closing QGIS Closed 2019-05-15
Duplicated by QGIS Application - Bug report #22092: Crash on close application Closed 2019-05-16
Duplicated by QGIS Application - Bug report #22102: QGIS 3.4.7 crash while closing Closed 2019-05-19

Associated revisions

Revision f76aa2a1
Added by Nyall Dawson 8 months ago

Cleanup geometry validation dock before QgsApplication exit

Refs #20283, possibly fixes it

Revision 8e834072
Added by Nyall Dawson 8 months ago

Cleanup geometry validation dock before QgsApplication exit

Refs #20283, possibly fixes it

History

#1 Updated by Nyall Dawson about 1 year ago

  • Status changed from Open to Feedback

This particular crash is usually caused by leftover files from a previous older version install. Can you try totally cleaning your install folder and reinstalling?

#2 Updated by Jerry Brand about 1 year ago

Everything is fine now. I did not experienced the issue again.

#3 Updated by Nyall Dawson about 1 year ago

  • Status changed from Feedback to Closed

#4 Updated by Jürgen Fischer about 1 year ago

#5 Updated by Jürgen Fischer about 1 year ago

#6 Updated by Jürgen Fischer about 1 year ago

  • Duplicated by Bug report #20314: QGIS 3.4 crashed when exiting immediately after saving added

#7 Updated by Jürgen Fischer about 1 year ago

#8 Updated by Jürgen Fischer about 1 year ago

#9 Updated by Jürgen Fischer about 1 year ago

#10 Updated by Jürgen Fischer about 1 year ago

#11 Updated by Jürgen Fischer about 1 year ago

#12 Updated by Jürgen Fischer about 1 year ago

#13 Updated by Jürgen Fischer about 1 year ago

  • Subject changed from Crash when exiting program to Crash when exiting program [proj_lpz_dist]

#14 Updated by Alessandro Pasotti about 1 year ago

#15 Updated by Jürgen Fischer about 1 year ago

#16 Updated by Jürgen Fischer about 1 year ago

  • Duplicated by Bug report #20618: QGis 3.4 reproducible crash while in idle state added

#17 Updated by Jürgen Fischer about 1 year ago

#18 Updated by Jürgen Fischer about 1 year ago

#19 Updated by Jürgen Fischer about 1 year ago

  • Duplicated by Bug report #20675: QGIS crashes after successful saving the project and trying to quit added

#20 Updated by Jürgen Fischer about 1 year ago

#21 Updated by Jürgen Fischer about 1 year ago

  • Duplicated by Bug report #20679: QGIS Crashed when closing project without saving added

#22 Updated by Jürgen Fischer about 1 year ago

  • Status changed from Closed to Reopened

#23 Updated by Jürgen Fischer about 1 year ago

#24 Updated by Jürgen Fischer about 1 year ago

#25 Updated by Jürgen Fischer about 1 year ago

#26 Updated by Jürgen Fischer about 1 year ago

#27 Updated by Jürgen Fischer 12 months ago

#28 Updated by Jürgen Fischer 12 months ago

#29 Updated by Jürgen Fischer 12 months ago

#30 Updated by Jürgen Fischer 12 months ago

#31 Updated by Jürgen Fischer 12 months ago

#32 Updated by Jürgen Fischer 11 months ago

#33 Updated by Jürgen Fischer 11 months ago

#34 Updated by Jürgen Fischer 11 months ago

#35 Updated by Jürgen Fischer 11 months ago

  • Duplicated by Bug report #20959: QGIS crash when saving and closing a project. added

#36 Updated by Jürgen Fischer 11 months ago

#37 Updated by Jürgen Fischer 11 months ago

#38 Updated by Jürgen Fischer 11 months ago

#39 Updated by Jürgen Fischer 11 months ago

#40 Updated by Jürgen Fischer 11 months ago

#41 Updated by Giovanni Manghi 11 months ago

#42 Updated by Jürgen Fischer 11 months ago

#43 Updated by Jürgen Fischer 11 months ago

#44 Updated by Jürgen Fischer 11 months ago

#45 Updated by Jürgen Fischer 11 months ago

#46 Updated by Jürgen Fischer 11 months ago

#47 Updated by Jürgen Fischer 11 months ago

#48 Updated by Jürgen Fischer 11 months ago

#49 Updated by Jürgen Fischer 11 months ago

#50 Updated by Jürgen Fischer 11 months ago

#51 Updated by Jürgen Fischer 11 months ago

#52 Updated by Jürgen Fischer 11 months ago

Nyall Dawson wrote:

This particular crash is usually caused by leftover files from a previous older version install. Can you try totally cleaning your install folder and reinstalling?

Can you elaborate? Which files?

#53 Updated by Phil Wyatt 11 months ago

Any further instructions with this issue - I have done a full delete of QGIS and reload and the problem still exists

#54 Updated by Phil Wyatt 11 months ago

After this crash I also get a "do you want to save the project" as soon as I reopen QGIS post crash - hope this helps with providing some solution

#55 Updated by Phil Wyatt 11 months ago

saving of "project" when reopening produced the attached file

#56 Updated by Jürgen Fischer 11 months ago

#57 Updated by Jürgen Fischer 11 months ago

#58 Updated by Jürgen Fischer 11 months ago

#59 Updated by Jürgen Fischer 11 months ago

#60 Updated by Jürgen Fischer 11 months ago

#61 Updated by Jürgen Fischer 11 months ago

#62 Updated by Jürgen Fischer 10 months ago

#63 Updated by Jürgen Fischer 10 months ago

#64 Updated by Jürgen Fischer 10 months ago

#65 Updated by Jürgen Fischer 10 months ago

  • Duplicated by Bug report #21208: Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63 added

#66 Updated by Jürgen Fischer 10 months ago

#67 Updated by Giovanni Manghi 10 months ago

#68 Updated by Jürgen Fischer 10 months ago

  • Duplicated by Bug report #21255: Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63 added

#69 Updated by Jürgen Fischer 10 months ago

#70 Updated by Jürgen Fischer 10 months ago

#71 Updated by Jürgen Fischer 10 months ago

  • Duplicated by Bug report #21334: QGIS crashes everytime I try to exit the program. added

#72 Updated by Jürgen Fischer 10 months ago

#73 Updated by Jürgen Fischer 10 months ago

#74 Updated by Jürgen Fischer 10 months ago

#75 Updated by Jürgen Fischer 10 months ago

#76 Updated by Jürgen Fischer 9 months ago

#77 Updated by Jürgen Fischer 9 months ago

#78 Updated by Jürgen Fischer 9 months ago

#79 Updated by Jorge Muñoz 9 months ago

It still persists in QGIS 3.6.0

Crash ID: f7df28f7223b7c16fa65832f9b1d942ae285d5c9

Stack Trace

RtlFreeHeap :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
clGetExtensionFunctionAddress :
execute_onexit_table :
execute_onexit_table :
execute_onexit_table :
QgsQtLocationConnection::qt_metacast :
QgsQtLocationConnection::qt_metacast :
RtlDeactivateActivationContextUnsafeFast :
LdrShutdownProcess :
RtlExitUserProcess :
ExitProcess :
exit :
exit :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.6.0-Noosa
QGIS code revision: 58734527ab
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.4.0
Running against GDAL: 2.4.0

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.16299

#80 Updated by Jürgen Fischer 9 months ago

  • Duplicated by Bug report #21512: QGIS Crashed- Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63 added

#81 Updated by Giovanni Manghi 9 months ago

#82 Updated by Diogo Vasconcelos 9 months ago

QGIS crashes most of the times after (during) exit, but not always.
It does not corrupt project file when exiting and saving changes.
I can't isolate the cause.

QGIS version
3.6.0-Noosa
QGIS code revision
58734527ab
Compiled against Qt
5.11.2
Running against Qt
5.11.2
Compiled against GDAL/OGR
2.4.0
Running against GDAL/OGR
2.4.0
Compiled against GEOS
3.7.0-CAPI-1.11.0
Running against GEOS
3.7.0-CAPI-1.11.0 673b9939
PostgreSQL Client Version
9.2.4
SpatiaLite Version
4.3.0
QWT Version
6.1.3
QScintilla2 Version
2.10.8
Compiled against PROJ
520
Running against PROJ
5.2.0

#83 Updated by Giovanni Manghi 9 months ago

Diogo Vasconcelos wrote:

QGIS crashes most of the times after (during) exit, but not always.

have you tried a new/clean profile?

#84 Updated by Diogo Vasconcelos 9 months ago

I've deleted my profile and started over. It crashed again.

Meanwhile I can make it crash now with the following steps:
Open QGIS
Open DB Manager
Execute Query on a Postgis Database.
Load the result
Save
Quit
QGIS crashes on exit.

Loading the query result seems to be the cause.

#85 Updated by Giovanni Manghi 9 months ago

Diogo Vasconcelos wrote:

I've deleted my profile and started over. It crashed again.

Meanwhile I can make it crash now with the following steps:
Open QGIS
Open DB Manager
Execute Query on a Postgis Database.
Load the result
Save
Quit
QGIS crashes on exit.

Loading the query result seems to be the cause.

I can't confirm this on qgis master.
Testing the same steps on 3.4.5 and 3.6 is at the moment not possible (so I don't understand how you was able to) because the functionality to load query layers from DB manager is broken (does not work on 3.6, crashes 3.4.5 when running the query).

#86 Updated by Diogo Vasconcelos 9 months ago

Sorry, I forgot to mention I did something to solve the issue referenced in #21353
I replaced the file in:
https://github.com/qgis/QGIS/blob/678f98c3557b0728729ac40144f6f4546f035b11/python/plugins/db_manager/dlg_sql_window.py
So, that's why I'm able to load query results.

But I can assure you QGIS was crashing on exit before this.
I can make it crash on exit with some queries. I made some simple test queries like "select * from public.teste" returning one point or one polygon and QGIS does not crash.
But I have more complex queries returning larger results that make QGIS crash on exit every time. I just can't figure out the true cause.

#87 Updated by Giovanni Manghi 9 months ago

I can make it crash on exit with some queries.

then please attach the data and an example of a query we can use to replicate the issue.

#88 Updated by Diogo Vasconcelos 9 months ago

I'm back in office after the weekend.
I no longer can make it crash with the same steps. It looks random now!
Sorry if I led you in the wrong direction but I was pretty sure it was reproducible.
I'll report again if I find anything.

#89 Updated by Jürgen Fischer 9 months ago

#90 Updated by Jürgen Fischer 9 months ago

#91 Updated by Jürgen Fischer 9 months ago

#92 Updated by Jürgen Fischer 9 months ago

#93 Updated by Jürgen Fischer 9 months ago

#94 Updated by Giovanni Manghi 9 months ago

#95 Updated by Jürgen Fischer 9 months ago

#96 Updated by Jürgen Fischer 9 months ago

#97 Updated by Jürgen Fischer 8 months ago

  • Duplicated by Bug report #21790: QGIS 3.4.4 crashes on Save when more than one copy running added

#98 Updated by Jürgen Fischer 8 months ago

#99 Updated by Jürgen Fischer 8 months ago

#100 Updated by Jürgen Fischer 8 months ago

#101 Updated by Jürgen Fischer 8 months ago

#102 Updated by Jürgen Fischer 8 months ago

#103 Updated by Jürgen Fischer 8 months ago

#104 Updated by Jürgen Fischer 8 months ago

#105 Updated by Jürgen Fischer 8 months ago

#106 Updated by Giovanni Manghi 8 months ago

#107 Updated by Jürgen Fischer 8 months ago

#108 Updated by Jürgen Fischer 8 months ago

#109 Updated by Jürgen Fischer 8 months ago

#110 Updated by Giovanni Manghi 8 months ago

#111 Updated by Jürgen Fischer 7 months ago

#112 Updated by Jürgen Fischer 7 months ago

#113 Updated by Jürgen Fischer 7 months ago

#114 Updated by Jürgen Fischer 7 months ago

#115 Updated by Jürgen Fischer 7 months ago

Also available in: Atom PDF