Bug report #20697

QGIS 3.4.2 crashes on exit

Added by Grant Boxer almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:3.4.2 Regression?:Yes
Operating System:Win10 and Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:28517

Description

User Feedback

QGIS crashes on exit

Report Details

Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63

Stack Trace

proj_lpz_dist :
proj_lpz_dist :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::QgsCoordinateTransform :
QHashData::free_helper :
QgsCoordinateTransform::addToCache :
QgsCoordinateTransform::invalidateCache :
QgsApplication::exitQgis :
QgisApp::~QgisApp :
CPLStringList::operator[] :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.2-Madeira
QGIS code revision: 22034aa070
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134


Related issues

Duplicates QGIS Application - Bug report #20283: Crash when exiting program [proj_lpz_dist] Reopened 2018-10-30
Duplicated by QGIS Application - Bug report #20757: crash when closing desktop application Closed 2018-12-08

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Operating System changed from Win10 to Win10 and Linux
  • Crashes QGIS or corrupts data changed from No to Yes

I've seen that randomly on linux too, it's probably due to the destruction of the static multihash sTransforms in QgsApplication::exitQgis

#2 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Unknown to Build/Install
  • Priority changed from Normal to High
  • Regression? changed from No to Yes

#3 Updated by Jürgen Fischer almost 2 years ago

#4 Updated by Giovanni Manghi almost 2 years ago

#5 Updated by Giovanni Manghi almost 2 years ago

#6 Updated by KL Higgins almost 2 years ago

Same here (every time I close QGIS 3.4.2 -- but no data is lost). Windows 10. x64

Crash ID: 7442373e0283e1ddab9b4be290841057a580a7ea

Stack Trace

proj_lpz_dist :
proj_lpz_dist :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::~QgsCoordinateTransform :
QgsPointLocator::~QgsPointLocator :
QgsPointLocator::~QgsPointLocator :
QgsSnappingUtils::clearAllLocators :
QgsSnappingUtils::~QgsSnappingUtils :
QgsVectorLayerProperties::`default constructor closure' :
QObjectPrivate::deleteChildren :
QWidget::~QWidget :
CPLStringList::operator[] :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.2-Madeira
QGIS code revision: 22034aa070
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

#7 Updated by Giovanni Manghi almost 2 years ago

#8 Updated by Giovanni Manghi almost 2 years ago

#9 Updated by Giovanni Manghi almost 2 years ago

#10 Updated by Jürgen Fischer almost 2 years ago

#11 Updated by Jürgen Fischer almost 2 years ago

#12 Updated by Jürgen Fischer almost 2 years ago

#13 Updated by Jürgen Fischer almost 2 years ago

#14 Updated by Jürgen Fischer almost 2 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Also available in: Atom PDF