Bug report #20816

Crash by closing Qgis 3.4.2

Added by N. Veenstra over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:3.4.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:28635

Description

Qgis is still many time crashing by closing down Qgis

User Feedback

Always this error by clossing down QGIS

Report Details

Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63

Stack Trace

proj_lpz_dist :
proj_lpz_dist :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::transformPolygon :
QgsCoordinateTransform::QgsCoordinateTransform :
QHashData::free_helper :
QgsCoordinateTransform::addToCache :
QgsCoordinateTransform::invalidateCache :
QgsApplication::exitQgis :
QgisApp::~QgisApp :
CPLStringList::operator[] :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.2-Madeira
QGIS code revision: 22034aa070
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134


Related issues

Duplicates QGIS Application - Bug report #20283: Crash when exiting program [proj_lpz_dist] Reopened 2018-10-30

History

#1 Updated by Giovanni Miduri over 1 year ago

N. Veenstra wrote:

Qgis is still many time crashing by closing down Qgis

User Feedback

Always this error by clossing down QGIS

Report Details

Crash ID: 62f1fcd2045780cb9f127836e6b579b8665f3e63

Stack Trace
[...]

QGIS Info
QGIS Version: 3.4.2-Madeira
QGIS code revision: 22034aa070
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

The same thing happens to me by closing only by the "close" button at the top right of the window.

User Feedback

Report Details

Crash ID: ffb50c831c4bb1f27a9b4d076b82aab571345eb0

Stack Trace

QMutex::lock :
QgsAuthManager::hasConfigId :
QMetaObject::activate :
QThread::finished :
QThread::currentThreadId :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.2-Madeira
QGIS code revision: 22034aa070
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

#2 Updated by Paolo Cavallini over 1 year ago

  • Status changed from Open to Feedback

Please try without plugins, as these are the most common cause of this problem.

#3 Updated by Paolo Cavallini over 1 year ago

  • Category changed from Unknown to Python plugins

#4 Updated by Paolo Cavallini over 1 year ago

Probable duplicate of #20210

#5 Updated by Jürgen Fischer over 1 year ago

#6 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF