Bug report #20989

QGIS crashes every time I click close

Added by Hugo de Vos over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.4.3 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:28808

Description

User Feedback

This occurs every time i shut down QGIS

Report Details

Crash ID: 88e28c5df1ce4c3f1b549b6728a1d960ecb5f111

Stack Trace

QgsMapToolExtent::~QgsMapToolExtent :
PyInit__gui :
QObjectPrivate::deleteChildren :
QWidget::~QWidget :
QgsVectorLayerProperties::`default constructor closure' :
QgisApp::~QgisApp :
CPLStringList::operator[] :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.3-Madeira
QGIS code revision: 2f64a3c4e7
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.4.0
Running against GDAL: 2.4.0

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

History

#1 Updated by Giovanni Manghi over 1 year ago

#2 Updated by Giovanni Manghi over 1 year ago

  • Resolution changed from fixed/implemented to duplicate
  • Status changed from Open to Closed

#3 Updated by Jürgen Fischer over 1 year ago

#4 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Closed to Open
  • Resolution deleted (duplicate)

Giovanni Manghi wrote:

#20283

judging from the stackstrace this doesn't look similar.

#5 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Feedback

This looks like a plugin bug -- can you try with a clean profile, and no plugins?

#6 Updated by Nyall Dawson over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF