Bug report #16428

Processing UI forms not rendering properly

Added by Frank Sokolic over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Processing/GUI
Affected QGIS version:master Regression?:Yes
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24337

Description

There is a problem with the layout of the form of the processing tools. I'm not able to use processing as a result of this.

All service providers seem to be affected: SAGA, GDAL, etc.

I removed the .qgis3 directory and restarted QGIS but this hasn't solved the problem.

Screenshot_from_2017-04-08_12-44-05.png (57 KB) Frank Sokolic, 2017-04-08 03:41 AM

Screenshot_from_2017-04-08_12-44-27.png (38 KB) Frank Sokolic, 2017-04-08 03:41 AM

Screenshot_from_2017-04-08_12-45-07.png (27.3 KB) Frank Sokolic, 2017-04-08 03:41 AM


Related issues

Duplicated by QGIS Application - Bug report #18207: Graphical modeler GUI is broken Closed 2018-02-25
Duplicated by QGIS Application - Bug report #18473: graphical modeler panels widgets are collapsed Closed 2018-03-17
Duplicated by QGIS Application - Bug report #17488: Processing Modeler: Defective GUI Closed 2017-11-17

Associated revisions

Revision 500175b8
Added by Denis Rouzaud over 2 years ago

remove QgsScrollAreaWidgetPlugin from custom widgets

it had to be removed form the widget list in uic plugin. It might be better to provide the real list of implemented widgets rather than the full gui list.

fixes #16428

Revision 87962254
Added by Nyall Dawson over 1 year ago

[processing] Fix bad layout for docks in modeler

Because there's some deep underlying issue which causes the dock
layouts to get corrupted in certain circumstances, avoid the
issue entirely by moving construction of the docks out of
the .ui file and instead do it all manually via Python code.

Fixes #16428, #19068

History

#1 Updated by Tim Sutton over 2 years ago

I also get this issue on Mac OS

#2 Updated by matteo ghetta over 2 years ago

Same issue on Linux Mint 18.1 with Cinnamon and Mate as desktop environments.

Some further information and clues:

1. problems started after this commit:

#aad182fdc041bd5e83be5b2b399cae496826c008

2. by removing the file `qgis_customwidgets.py` from here:

/usr/lib/python3/dist-packages/PyQt4/uic/widget-plugins/qgis_customwidgets.py

then Processing looks fine but other plugins with custom qgis widget created in Qt Designer are broken and in Qt Designer all the qgis widgets have disappeared

#3 Updated by Frank Sokolic over 2 years ago

I've just upgraded my OS to Ubuntu 17.04 and the problem still occurs. I also uninstalled and then reinstalled QGIS but this didn't solve the problem either.

#4 Updated by Alexander Bruy over 2 years ago

  • Description updated (diff)
  • Assignee changed from Victor Olaya to Nyall Dawson

Probably related to Qt version.

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#6 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#7 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#8 Updated by Richard Duivenvoorde over 2 years ago

I had this problem too (Debian testing... now stable :-) ),
could not use/show processing untill I used Matteo's 'trick': remove(!)

/usr/lib/python3/dist-packages/PyQt5/uic/widget-plugins/qgis_customwidgets.py

and restart QGIS3, then all seems ok. To me it looks like there is something in the
qgis_customwidgets.py which brings havoc to my gui.

Every time I compile/install Master off course it is placed back.
In the header of the file it mentions PyQt4:

/pythonX/dist-packages/PyQt4/uic/widget-plugins/

is it still used?

#9 Updated by Richard Duivenvoorde over 2 years ago

Version info:

QGIS version
2.99.0-Master
QGIS code branch
Release 2.99
Compiled against Qt
5.7.1
Running against Qt
5.7.1
Compiled against GDAL/OGR
2.1.2
Running against GDAL/OGR
2.1.2
Compiled against GEOS
3.5.1-CAPI-1.9.1
Running against GEOS
3.5.1-CAPI-1.9.1 r4246
PostgreSQL Client Version
9.6.3
SpatiaLite Version
4.3.0a
QWT Version
6.1.2
PROJ.4 Version
493
QScintilla2 Version
2.9.3
This copy of QGIS writes debugging output.

Also see this thread: https://lists.osgeo.org/pipermail/qgis-developer/2017-June/048905.html

#10 Updated by Denis Rouzaud over 2 years ago

This might comes from the fact that QGIS python lib is not installed (not in path), so running qgis_customwidgets.py fails.
Anyone can confirm that installing QGIS in system actually solves the issue?

#11 Updated by Frank Sokolic over 2 years ago

Denis, not sure what you mean by "Anyone can confirm that installing QGIS in system actually solves the issue?". Are you referring to the path?

#12 Updated by Denis Rouzaud over 2 years ago

It was a misunderstanding on my side.

I think that compiling the ui files using pyuic directly when building would solve the issue.
I'm on it.

#13 Updated by Denis Rouzaud over 2 years ago

I can't find the issue here.
Tried to use pyuic without success.
Tried to remove QgsScrollArea from custom widgets (which seems to be causing the issue here) without success.

#14 Updated by Etienne Trimaille over 2 years ago

I tried to rename the only file `qgis_customwidgets.py` but it's still not working for me, I can't open Processing in master.

$ find /Users/etienne/dev/ -name *qgis_customwidgets.py
/Users/etienne/dev//c/QGIS/python/custom_widgets/BREAK_qgis_customwidgets.py

#15 Updated by Frank Sokolic over 2 years ago

Renaming worked for me:

$ cd /usr/lib/python3/dist-packages/PyQt5/uic/widget-plugins
$ sudo mv qgis_customwidgets.py qgis_customwidgets.p

This is on Ubuntu 17.04.

#16 Updated by Denis Rouzaud over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#17 Updated by Regis Haubourg over 1 year ago

  • Status changed from Closed to Open

Still true in current master.

Renaming the qgis_customwidgets.py works for me.

#18 Updated by Alexander Bruy over 1 year ago

#19 Updated by Alexander Bruy over 1 year ago

  • Duplicated by Bug report #18473: graphical modeler panels widgets are collapsed added

#20 Updated by Alexander Bruy over 1 year ago

#21 Updated by Mario Baranzini over 1 year ago

I have the same problem with QGIS 3.0.3 compiled on Archlinux.

Removing

/usr/lib/python3.6/site-packages/PyQt5/uic/widget-plugins/qgis_customwidgets.py
doesn't work. The file is created again at each QGIS launch.

Edit: sorry, I was wrong. Removing the file works for me too.

#22 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF