Bug report #17488

Processing Modeler: Defective GUI

Added by Andreas Schmid almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Linux (Ubuntu/Mint), macOS Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:25385

Description

In Processing Modeler, the GUI of the Inputs and Algorithms panels is defective. (Does not resize correctly.) See screenshot attached.

modeler gui.png (21 KB) Andreas Schmid, 2017-11-17 02:39 PM

processing_modelerer_kde.png (47.4 KB) Andreas Neumann, 2017-11-29 04:56 PM


Related issues

Related to QGIS Application - Bug report #18473: graphical modeler panels widgets are collapsed Closed 2018-03-17
Duplicates QGIS Application - Bug report #16428: Processing UI forms not rendering properly Closed 2017-04-08

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

Confirmed here on ubuntu 16.04.

#2 Updated by Larry Shaffer almost 3 years ago

Also here on macOS. I had a fix, that has to do with object parenting and layout insertion, but unfortunately can not find it.

Basically, the faulty widget needs to be specifically added to the layout of the panel, not just assigned the panel as its parent (or something like that).

#3 Updated by Alexander Bruy almost 3 years ago

  • Status changed from Open to Feedback

Not reproducible on Linux (17ad093, self-compiled) and Windows 7 (installed via OSGeo4W, qgis-dev-2.99.0-224 from November, 23). Please check if you have QGIS custom widgets library from previous versions somewhere in the system.

#4 Updated by Andreas Schmid almost 3 years ago

  • Status changed from Feedback to Open

Not reproducible on Ubuntu 17.10 with self-compiled Version cd0ba91.

Reproducible on a clean Ubuntu 17.10 when using the nightly build Ubuntu packages (cd0ba91). (Sorry that I didn't mention in the bug description that I was using the nightly builds.)

So it has to do with packaging?

#5 Updated by Giovanni Manghi almost 3 years ago

Andreas Schmid wrote:

Not reproducible on Ubuntu 17.10 with self-compiled Version cd0ba91.

Reproducible on a clean Ubuntu 17.10 when using the nightly build Ubuntu packages (cd0ba91). (Sorry that I didn't mention in the bug description that I was using the nightly builds.)

So it has to do with packaging?

apparently yes. I also can't confirm on windows/osgeo4w but see it on any master installation on Ubuntu/mint did with the repo for master.

#6 Updated by Giovanni Manghi almost 3 years ago

  • Operating System changed from Ubuntu 17.10 to Linux (Ubuntu/Mint), macOS
  • Regression? changed from Yes to No
  • Priority changed from High to Normal
  • Assignee deleted (Victor Olaya)
  • Category changed from Processing/Modeller to Build/Install

#7 Updated by Andreas Neumann almost 3 years ago

Same issue for me on Ubuntu 17.10, KDE-Plasma, qt 5.9.1

With self-compiled master version de3aa0c9f8

See also screenshot attached

#8 Updated by Kory Roberts almost 3 years ago

Confirmed on Linux Mint 18.3 Cinnamon, QGIS 2.99 c4aa4d0, Qt 5.5.1.

#9 Updated by Mathieu Pellerin - nIRV almost 3 years ago

Removing the file "qgis_customwidgets.py" from /usr/lib/python3/dist-packages/PyQt5/uic/widget-plugins should fix the modeler.

Locate the file on your system if it's not in the above-mentioned path.

#10 Updated by Randal Hale almost 3 years ago

I just gave this a shot on Ubuntu 17.10 QGIS Build d8402ac and it worked. I finally have a Processing Modeler that looks like it should look and hopefully works correctly.

#11 Updated by Jürgen Fischer over 2 years ago

#12 Updated by Regis Haubourg over 2 years ago

  • Priority changed from Normal to High

#13 Updated by Alexander Bruy over 2 years ago

#14 Updated by Alexander Bruy over 2 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicates #16428

Also available in: Atom PDF