Bug report #19068

Error with the process modeler interface

Added by Samuel Fernando Mesa Giraldo over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Modeller
Affected QGIS version:3.0.3 Regression?:No
Operating System:Arch Linux x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26898

Description

Since version 3.0.2 I have encountered problems with the graphical interface of the process modeler, the definition of model parameters and properties is not displayed.

The error is in the ArchLinux x64 distribution

Associated revisions

Revision 87962254
Added by Nyall Dawson over 2 years ago

[processing] Fix bad layout for docks in modeler

Because there's some deep underlying issue which causes the dock
layouts to get corrupted in certain circumstances, avoid the
issue entirely by moving construction of the docks out of
the .ui file and instead do it all manually via Python code.

Fixes #16428, #19068

History

#1 Updated by Nyall Dawson over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF