Bug report #18260

qgis 3 crashes at start

Added by matthieu carlini over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Browser
Affected QGIS version:3.3(master) Regression?:No
Operating System:windows 7 pro Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:26151

Description

I have installed QGIS 3 on 2 windows 7 pro. On my professional laptop (dell latitude E7250) QGIS crashes systematicaly at startup.
I have tested install with QGIS 2.18 on the system, or without, after removing all preferences. The reload button make nothing.

User Feedback

Report Details

Crash ID: b06dc2da84bd293756294c5be15a42a454cc305b

Stack Trace

RtlFreeHeap :
SleepMon :
HeapFree :
free :
DllUnregisterServer :
DllUnregisterServer :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
DllGetClassObjectWOW :
DllGetClassObjectWOW :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
ObjectStublessClient6 :
CoCreateInstanceEx :
ObjectStublessClient32 :
SHParseDisplayName :
Ordinal866 :
ILSaveToStream :
ShellExecuteExW :
ShellExecuteExW :
ShellExecuteExW :
Ordinal860 :
ShellExecuteExW :
ExtractIconExW :
Ordinal865 :
Ordinal865 :
QWidgetPrivate::registerDropSite :
QStackedWidget::`default constructor closure' :
QInputDialog::getInteger :
QgsDataCollectionItem::iconDir :
QgsDirectoryItem::icon :
QgsBrowserModel::data :
QSortFilterProxyModel::data :
QModelIndex::data :
QStyledItemDelegate::initStyleOption :
QStyledItemDelegate::sizeHint :
QTreeView::indexRowSizeHint :
QTreeViewPrivate::itemHeight :
QTreeViewPrivate::lastVisibleItem :
QTreeView::sizeHintForColumn :
QHeaderView::resizeSections :
QHeaderView::sectionPosition :
QHeaderView::sectionViewportPosition :
QHeaderView::resizeSection :
QHeaderView::setStretchLastSection :
QgsBrowserDockWidget::showEvent :
QWidget::event :
QDockWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::show_helper :
QWidgetPrivate::showChildren :
QWidgetPrivate::show_helper :
QWidget::setVisible :
QgisApp::QgisApp :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601


Related issues

Related to QGIS Application - Bug report #19962: QGIS Crashes on Open Window Closed 2018-09-26
Related to QGIS Application - Bug report #21730: QGIS crashes on "Open project" Feedback 2019-04-02
Duplicated by QGIS Application - Bug report #18391: Crash on opening Closed 2018-03-08
Duplicated by QGIS Application - Bug report #18794: QGIS 3.0.2 crash on startup Closed 2018-04-23
Duplicated by QGIS Application - Bug report #19759: crash in browser Closed 2018-09-03
Duplicated by QGIS Application - Bug report #18570: QGIS 3.0.1 crash on startup Closed 2018-03-26
Duplicated by QGIS Application - Bug report #18616: Crash following install and QGIS 3.0.1 will not open Closed 2018-04-03
Duplicated by QGIS Application - Bug report #19181: Crash on Start Closed 2018-06-12
Duplicated by QGIS Application - Bug report #19696: QGIS crashes upon launching Closed 2018-08-25
Duplicated by QGIS Application - Bug report #19899: very unstable installation of QGIS 3.2.3 on Windows 7 Mac... Closed 2018-09-19
Duplicated by QGIS Application - Bug report #19907: qgis 3.2 crashes at start Closed 2018-09-21
Duplicated by QGIS Application - Bug report #18548: QGIS 3.0.1 crash on startup Closed 2018-03-26
Duplicated by QGIS Application - Bug report #18427: Impossible d'ouvrir QGIS 3.0 Closed 2018-03-13
Duplicated by QGIS Application - Bug report #19357: QGIS 3.2 Launching crashed Closed 2018-07-09
Duplicated by QGIS Application - Bug report #18706: QGIS 3 refuses to load on fresh OSGEO64 install on Window... Closed 2018-04-10
Duplicated by QGIS Application - Bug report #18654: QGIS 3.0.0 repeated crashing on opening Closed 2018-04-06
Duplicated by QGIS Application - Bug report #20030: Crashes every time I try to save Closed 2018-10-05
Duplicated by QGIS Application - Bug report #18505: Open OGR Supported Vector Datasets Closed 2018-03-21
Duplicated by QGIS Application - Bug report #19922: screen freezes (qgis program crashes) Closed 2018-09-22
Duplicated by QGIS Application - Bug report #19846: crash when saving projects Closed 2018-09-14
Duplicated by QGIS Application - Bug report #18948: crash when selecting a path Closed 2018-05-13
Duplicated by QGIS Application - Bug report #20356: QGIS 3.4 crashes right after opening a windows explorer f... Closed 2018-11-04
Duplicated by QGIS Application - Bug report #20498: Crash on loading a vector layer Closed 2018-11-15
Duplicated by QGIS Application - Bug report #19629: Crash on New Shapefile Layer Closed 2018-08-15
Duplicated by QGIS Application - Bug report #20214: QGIS crashes when trying to load xml file for new svgs in... Closed 2018-10-25
Duplicated by QGIS Application - Bug report #20746: QGIS 3.4 is very unstable on my Windows 10 laptop Closed 2018-12-06
Duplicated by QGIS Application - Bug report #20787: QGIS 3.4.2 keeps crashing in Windows 7 Closed 2018-12-12
Duplicated by QGIS Application - Bug report #20960: QGIS crash when i click on open or save icon or menu. Closed 2019-01-10

Associated revisions

Revision 4911d2e7
Added by Jürgen Fischer almost 2 years ago

[BUGFIX][NEEDS-DOCS] add command line option to hide browser (refs #18260)

Revision 5508ea03
Added by Nyall Dawson almost 2 years ago

Use a custom folder icon instead of O/S folder icon

...because using O/S folder icon can causes crashes.

Fixes #18260

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

#2 Updated by Thomas NOIROT over 2 years ago

I have also the same problem. Here is my log :

Crash ID: 2da396b26f43211ca81fa880817113c91d7a7715

Stack Trace

RtlFreeHeap :
HeapFree :
free :
DllUnregisterServer :
DllUnregisterServer :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
DllGetClassObjectWOW :
DllGetClassObjectWOW :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
ObjectStublessClient6 :
CoCreateInstanceEx :
ObjectStublessClient32 :
SHParseDisplayName :
Ordinal866 :
ILSaveToStream :
ShellExecuteExW :
ShellExecuteExW :
ShellExecuteExW :
Ordinal860 :
ShellExecuteExW :
ExtractIconExW :
Ordinal865 :
Ordinal865 :
QWidgetPrivate::registerDropSite :
QStackedWidget::`default constructor closure' :
QInputDialog::getInteger :
QgsDataCollectionItem::iconDir :
QgsDirectoryItem::icon :
QgsBrowserModel::data :
QSortFilterProxyModel::data :
QModelIndex::data :
QStyledItemDelegate::initStyleOption :
QStyledItemDelegate::sizeHint :
QTreeView::indexRowSizeHint :
QTreeViewPrivate::itemHeight :
QTreeViewPrivate::updateScrollBars :
QTreeView::updateGeometries :
QAbstractItemView::doItemsLayout :
QTreeView::doItemsLayout :
QTreeView::sizeHintForColumn :
QHeaderView::resizeSections :
QHeaderView::sectionPosition :
QHeaderView::sectionViewportPosition :
QHeaderView::resizeSection :
QHeaderView::setStretchLastSection :
QgsBrowserDockWidget::showEvent :
QWidget::event :
QDockWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::show_helper :
QWidgetPrivate::showChildren :
QWidgetPrivate::show_helper :
QWidget::setVisible :
QgisApp::QgisApp :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

#3 Updated by Stefan Wannemacher over 2 years ago

We had the same problem (see #18306).
We use the QGIS from OSGeo4W and have to use a proxy with authentication for webaccess.
I edited the file bin/qgis.bat and added --noversioncheck at the last line (start "QGIS" /B "%OSGEO4W....." --noversioncheck %*

#4 Updated by matthieu carlini over 2 years ago

I don't know if the problem is really the same. The installation of Qgis is the standalone in my case and i don't use proxy for webaccess. I've edited the line in qgis.bat but it doesn't make any difference, qgis always crash on startup.

#5 Updated by Jürgen Fischer over 2 years ago

#6 Updated by Harrissou Santanna over 2 years ago

#7 Updated by Charly Tristavirs over 2 years ago

I tried to add the --noversioncheck at the last line of qgis.bat.

There is no difference stating QGIS 3.0.

The CRash ID changed Crash ID: 4e4ffc7725df85c6d291d1221e547bbb37eb3b64

Trying again, crash ID becomes : Crash ID: 2da396b26f43211ca81fa880817113c91d7a7715 like the first time.

I don't know if it's important

Thank u very much

#8 Updated by matthieu carlini over 2 years ago

bug always occurs in 3.0.1

User Feedback

Report Details

Crash ID: b06dc2da84bd293756294c5be15a42a454cc305b

Stack Trace

RtlFreeHeap :
SleepMon :
HeapFree :
free :
DllUnregisterServer :
DllUnregisterServer :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
DllGetClassObjectWOW :
DllGetClassObjectWOW :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
ObjectStublessClient6 :
CoCreateInstanceEx :
ObjectStublessClient32 :
SHParseDisplayName :
Ordinal866 :
ILSaveToStream :
ShellExecuteExW :
ShellExecuteExW :
ShellExecuteExW :
Ordinal860 :
ShellExecuteExW :
ExtractIconExW :
Ordinal865 :
Ordinal865 :
QWidgetPrivate::registerDropSite :
QStackedWidget::`default constructor closure' :
QInputDialog::getInteger :
QgsDataCollectionItem::iconDir :
QgsDirectoryItem::icon :
QgsBrowserModel::data :
QSortFilterProxyModel::data :
QModelIndex::data :
QStyledItemDelegate::initStyleOption :
QStyledItemDelegate::sizeHint :
QTreeView::indexRowSizeHint :
QTreeViewPrivate::itemHeight :
QTreeViewPrivate::lastVisibleItem :
QTreeView::sizeHintForColumn :
QHeaderView::resizeSections :
QHeaderView::sectionPosition :
QHeaderView::sectionViewportPosition :
QHeaderView::resizeSection :
QHeaderView::setStretchLastSection :
QgsBrowserDockWidget::showEvent :
QWidget::event :
QDockWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::show_helper :
QWidgetPrivate::showChildren :
QWidgetPrivate::show_helper :
QWidget::setVisible :
QgisApp::QgisApp :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.1-Girona
QGIS code revision: a86bec25eb
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

#9 Updated by Harrissou Santanna over 2 years ago

#10 Updated by Jürgen Fischer over 2 years ago

#11 Updated by Jürgen Fischer almost 2 years ago

#12 Updated by Jürgen Fischer almost 2 years ago

#13 Updated by Jürgen Fischer almost 2 years ago

  • Duplicated by Bug report #18616: Crash following install and QGIS 3.0.1 will not open added

#14 Updated by Jürgen Fischer almost 2 years ago

#15 Updated by Jürgen Fischer almost 2 years ago

#16 Updated by Jürgen Fischer almost 2 years ago

  • Duplicated by Bug report #19899: very unstable installation of QGIS 3.2.3 on Windows 7 Machine added

#17 Updated by Jürgen Fischer almost 2 years ago

#18 Updated by Jürgen Fischer almost 2 years ago

  • Category changed from Build/Install to Browser

The backtrace suggests that this is related to the browser (widget). I suspect that there are third party file types (maybe even a common one) with explorer extensions (eg. for previews) on the affected machines, that are triggered by showing the browser widget. Does the crash happen when the splash screen shows "Restore window state"?

In 4911d2e74 I added a new command line option --hide-browser that should hide the browser, which is otherwise enabled by default and setting this should enable the application to start. Please check if specifying helps.

#19 Updated by Jürgen Fischer almost 2 years ago

#20 Updated by Jürgen Fischer almost 2 years ago

#21 Updated by Jürgen Fischer almost 2 years ago

#22 Updated by Jürgen Fischer almost 2 years ago

#23 Updated by Jürgen Fischer almost 2 years ago

  • Affected QGIS version changed from 3.0.0 to 3.3(master)

#24 Updated by Jürgen Fischer almost 2 years ago

#25 Updated by Jürgen Fischer almost 2 years ago

  • Duplicated by Bug report #18706: QGIS 3 refuses to load on fresh OSGEO64 install on Windows 7 Pro added

#26 Updated by Jürgen Fischer almost 2 years ago

#27 Updated by Jürgen Fischer almost 2 years ago

#28 Updated by Jürgen Fischer almost 2 years ago

#19962 might be related and also has a recipe to disable explorer extensions.

#29 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

#30 Updated by Jürgen Fischer over 1 year ago

#31 Updated by Jürgen Fischer over 1 year ago

#32 Updated by Jürgen Fischer over 1 year ago

#33 Updated by Jürgen Fischer over 1 year ago

#34 Updated by Jürgen Fischer over 1 year ago

#35 Updated by Jürgen Fischer over 1 year ago

#36 Updated by Jürgen Fischer over 1 year ago

#37 Updated by Jürgen Fischer over 1 year ago

  • Duplicated by Bug report #20356: QGIS 3.4 crashes right after opening a windows explorer file picker window added

#38 Updated by Jürgen Fischer over 1 year ago

#39 Updated by Jürgen Fischer over 1 year ago

#40 Updated by Jürgen Fischer over 1 year ago

  • Duplicated by Bug report #20214: QGIS crashes when trying to load xml file for new svgs in style manager added

#41 Updated by Rion Lerm over 1 year ago

Jürgen Fischer wrote:

The backtrace suggests that this is related to the browser (widget). I suspect that there are third party file types (maybe even a common one) with explorer extensions (eg. for previews) on the affected machines, that are triggered by showing the browser widget. Does the crash happen when the splash screen shows "Restore window state"?

In 4911d2e74 I added a new command line option --hide-browser that should hide the browser, which is otherwise enabled by default and setting this should enable the application to start. Please check if specifying helps.

Hi @Jürgen Fischer,

my QGIS 3.4 won't startup now with the "restoring window state" message displaying and Processing Toolbox partially showing.

#42 Updated by Jürgen Fischer over 1 year ago

  • Duplicated by Bug report #20746: QGIS 3.4 is very unstable on my Windows 10 laptop added

#43 Updated by Jürgen Fischer over 1 year ago

#44 Updated by Jürgen Fischer over 1 year ago

  • Duplicated by Bug report #20960: QGIS crash when i click on open or save icon or menu. added

#45 Updated by Jürgen Fischer over 1 year ago

Also available in: Atom PDF