Bug report #20356

QGIS 3.4 crashes right after opening a windows explorer file picker window

Added by Josh Rosenthal about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Windows Package
Affected QGIS version:3.4.0 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:28177

Description

User Feedback

Crash occurs whenever qgis goes to a windows explorer file picker window. UI stays interactive for a moment, and then freezes, then you get the crash message. - eg: layout : export as pdf, layout : image item properties : select image path, map : export as image, etc. Map : Open From crashes, but doesn't show the crash reporter window.

Clicking quickly to select or enter a filename before the crash doesn't work - still crashes

QGIS 3.4 installed via standalone worked fine for a few days (built map, numerous exports etc), then started the crashes preventing me from exporting my map. I installed the OSGeo4W version and for a time ran that successfully, then the crashes started there too.

Things I've tried:
Uninstalled, revo uninstaller to clean up registry, cccleaner for the same, deleted profile from user/APPDATA

1) Any advice of how to get qgis working properly (not crashing on export as pdf) or
2) Any way to export as pdf via a command line option that doesn't involve a file picker?

Below are a few different stack traces from different crashes in case thats helpful
h2. 1) Report Details from crash at Layout Export to PDF
Crash ID: b698ac1db19710a8915a9eb09597fc1faeecc120

Stack Trace

RtlFreeHeap :
free :
DllUnregisterServer :
DllUnregisterServer :
Ordinal67 :
CoGetProcessIdentifier :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoCreateInstance :
CoCreateInstance :
CoCreateInstance :
SHCreateItemInKnownFolder :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
NeverProvidedByJunction :
NeverProvidedByJunction :
NeverProvidedByJunction :
DllCanUnloadNow :
SHCreateItemWithParent :
SHCreateItemWithParent :
SHCreateItemWithParent :
GetScaleFactorForMonitor :
A_SHAUpdate :
RtlReleaseSRWLockExclusive :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.0-Madeira
QGIS code revision: 4a4b62ed19
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

2) Report Details from selecting vector layer data source
Crash ID: b698ac1db19710a8915a9eb09597fc1faeecc120

Stack Trace

RtlFreeHeap :
free :
DllUnregisterServer :
DllUnregisterServer :
Ordinal67 :
CoGetProcessIdentifier :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoCreateInstance :
CoCreateInstance :
CoCreateInstance :
SHCreateItemInKnownFolder :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
NeverProvidedByJunction :
NeverProvidedByJunction :
NeverProvidedByJunction :
DllCanUnloadNow :
SHCreateItemWithParent :
SHCreateItemWithParent :
SHCreateItemWithParent :
GetScaleFactorForMonitor :
A_SHAUpdate :
RtlReleaseSRWLockExclusive :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.4.0-Madeira
QGIS code revision: 4a4b62ed19
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

qgis_crash_onmap_export2pdfDELL-7F8K362.LOG Magnifier - debugview log (166 KB) Josh Rosenthal, 2018-11-04 07:04 PM

QGIS_CRASH_SOLUTION.png (90.9 KB) Felipe Souza, 2019-02-07 01:31 PM


Related issues

Duplicates QGIS Application - Bug report #18260: qgis 3 crashes at start Closed 2018-02-28

History

#1 Updated by Josh Rosenthal about 2 years ago

Another stack trace, this time from map: export to pdf. Also, attached is a debugview log (though there were no messages between initiating the save as interface and the crash, so this may be of limited use

Crash ID: bfeccad7d29abebecd4757380183e4ac9ae87f61

Stack Trace

RtlFreeHeap :
free :
DllUnregisterServer :
DllUnregisterServer :
Ordinal67 :
CoGetProcessIdentifier :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoCreateInstance :
CoCreateInstance :
CoCreateInstance :
SHCreateItemInKnownFolder :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
NeverProvidedByJunction :
NeverProvidedByJunction :
NeverProvidedByJunction :
Ordinal873 :
NeverProvidedByJunction :
NeverProvidedByJunction :
DllCanUnloadNow :
SHCreateItemWithParent :
SHCreateItemWithParent :
SHCreateItemWithParent :
GetScaleFactorForMonitor :
A_SHAUpdate :
RtlReleaseSRWLockExclusive :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.5.0-Master
QGIS code revision: 15b2352ea2
Compiled against Qt: 5.11.2
Running against Qt: 5.11.2
Compiled against GDAL: 2.3.2
Running against GDAL: 2.3.2

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

#2 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

Please test with 3.4.1

#3 Updated by Saber Razmjooei about 2 years ago

  • Assignee deleted (Jürgen Fischer)

#4 Updated by Josh Rosenthal about 2 years ago

Same issue occurs in 3.4.1, 3.5 dev, and 3.4.0

#5 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Feedback to Open

#6 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Rejected
  • Resolution set to up/downstream

This almost certainly a local issue only - see #19962 for debugging steps for a similar crash caused by other software installed on the workstation.

#7 Updated by Josh Rosenthal about 2 years ago

Confirmed, followed the #19962 debugging steps. I used ShellExView to view and disable all non microsoft shell extensions, and then qgis worked properly. Thank you!

#8 Updated by Jürgen Fischer about 2 years ago

  • Status changed from Rejected to Closed
  • Resolution changed from up/downstream to duplicate

#9 Updated by Jürgen Fischer about 2 years ago

#10 Updated by Felipe Souza almost 2 years ago

Josh Rosenthal wrote:

Confirmed, followed the #19962 debugging steps. I used ShellExView to view and disable all non microsoft shell extensions, and then qgis worked properly. Thank you!

I had the same problem and it was solved using ShellExView. Same thing. I installed it, under Options - Hide All Microsoft Extensions. Then Control + A to check all files, right mouse button and 'DISABLE SELECTED ITEMS'.

Thank you!

Also available in: Atom PDF