Bug report #19629

Crash on New Shapefile Layer

Added by Worth Lutz almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:3.2.1 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:27456

Description

User Feedback

- Start QGIS 3.2.1
- click the "Open Shapefile Layer" toolbar button
-> QGIS opens the "New Shapefile Layer" dialog
- click the "..." button next to the File Name input
-> QGIS opens a "Save Layer As" dialog and immediately CRASHES -> "Oh Uh!" dialog

Report Details

Crash ID: e7e0f6a8f5d80a6b06b4605f526cda35950e6a3c

Stack Trace

RtlFreeHeap :
free :
DllUnregisterServer :
DllUnregisterServer :
Ordinal67 :
CoGetProcessIdentifier :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoCreateInstance :
CoCreateInstance :
CoCreateInstance :
SHCreateItemInKnownFolder :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
NeverProvidedByJunction :
NeverProvidedByJunction :
NeverProvidedByJunction :
DllCanUnloadNow :
SHCreateItemWithParent :
SHCreateItemWithParent :
SHCreateItemWithParent :
GetScaleFactorForMonitor :
A_SHAUpdate :
RtlReleaseSRWLockExclusive :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.1-Bonn
QGIS code revision: 1edf372fb8
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134


Related issues

Duplicates QGIS Application - Bug report #18260: qgis 3 crashes at start Closed 2018-02-28

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Unknown to Vectors
  • Status changed from Open to Feedback

Can't confirm here. Clean 3.2 installation on win10. Please try again with a clean profile.

#2 Updated by Worth Lutz almost 2 years ago

  • Status changed from Feedback to Open

I uninstalled all versions of QGIS from my computer and renamed the .qgis2 folder.

I downloaded latest standalone version of QGIS 3.2 and installed it.

Problem still exists. Crash every time I click the "..." button.

After reinstall, QGIS still knows recent projects so something was not uninstalled but I do not know where this information is stored.

#3 Updated by Worth Lutz almost 2 years ago

Additional information:

I have a test project where I was able to load data. When I try to export a layer to a geopackage, I get the same crash
when I click the "..." button to browse to the correct directory.

#4 Updated by Worth Lutz almost 2 years ago

User Feedback

Start QGIS
click open project button
QGIS opens "Choose a QGIS Project File to Open" dialog and then crashes to this "Oh Uh!" dialog.

I can open the project which shows up in "recent projects". This is very frustrating as I'd like to try QGIS 3.

Report Details

Crash ID: ce53054575767fc71c3d105545424a4f9ef29a50

Stack Trace

RtlFreeHeap :
free :
DllUnregisterServer :
DllUnregisterServer :
Ordinal67 :
CoGetProcessIdentifier :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
Ordinal112 :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoGetProcessIdentifier :
CoCreateInstance :
CoCreateInstance :
CoCreateInstance :
SHCreateItemInKnownFolder :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
Ordinal61 :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
SHELL32_IconOverlayManagerInit :
NeverProvidedByJunction :
NeverProvidedByJunction :
NeverProvidedByJunction :
Ordinal873 :
NeverProvidedByJunction :
NeverProvidedByJunction :
DllCanUnloadNow :
SHCreateItemWithParent :
SHCreateItemWithParent :
SHCreateItemWithParent :
GetScaleFactorForMonitor :
A_SHAUpdate :
RtlReleaseSRWLockExclusive :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.1-Bonn
QGIS code revision: 1edf372fb8
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

#5 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Worth Lutz wrote:

I uninstalled all versions of QGIS from my computer and renamed the .qgis2 folder.

the .qgis2 folder is for QGIS 2.* not 3.*

In QGIS 3 please try with a new, clean profile: settings > user profiles.

#6 Updated by Worth Lutz almost 2 years ago

  • Status changed from Feedback to Open

I realized .qgis2 was for QGIS 2. I just uninstalled everything just in case.

I created a new profile which started up a new window of QGIS 3.

I clicked the new shapefile button and then the "..." and the "Save Layer As" dialog opened. I tried to change directory and the entire application disappeared.

I tried again with another new profile and now it crashes to the Crash dialog immediately after Opening the "Save Layer AS" dialog.

Further testing:

Open QGIS. Create a new profile. Click the "Open Project Button". Crash after dialog opens.

Is there any more information I can supply to help solve this?

#7 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Is there any more information I can supply to help solve this?

hard to say, it is clearly a local issue because if it was a general one we would have received many more reports about it. If you had other/old qgis installations in the same machine you could try something more drastic, such removing any qgis windows registry entry (I have seen such approach work in some case).

#8 Updated by Worth Lutz almost 2 years ago

  • Status changed from Feedback to Open

I have now deleted everything I can find on this computer related to QGIS including all the registry entries, QGIS v2 and v3.

No change. :(

I even tried creating a new Windows user and tried there. No luck. :(

The crash occurs any where I click the "..." button. In: New Shapefile Layer, New GeoPackage Layer, New SpatiaLite Layer.
Also when I click the Open Project button.

Could QGIS be looking at a file or directory which has bad/incorrect permissions? It is opening my Windows User directory when opening the file dialog just before it crashes. What could I have broken?

Maybe I just need to get a new computer. :|

#9 Updated by Worth Lutz almost 2 years ago

I found some more QGIS items in the registry and deleted them. I have searched the registry and see no more. I made sure all versions of QGIS were uninstalled. After an additional reinstall of v3.2.2 , it still crashes. Something is broken on my laptop.

I created a Windows 10 VM on my Linux Desktop and installed QGIS 3.2.2 and it works. This is definitely a local issue on my laptop. It is related to the open or save file dialog and not necessarily the New Shapefile dialog.

I can get a crash consistently by clicking the "Open Project" button. The dialog opens and the program crashes before I even have a chance to change directory and choose a project.

Someone with the ability may want to change the title to "crash at open project dialog", set the category appropriately and change the version to v3.2.2.

This issue can probably be closed as it seems to be a problem with my computer.

#10 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Closing as it seems to be a local issue.

#11 Updated by Jürgen Fischer over 1 year ago

Also available in: Atom PDF