Bug report #18391

Crash on opening

Added by Ben Neely about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:26281

Description

Greetings -- I have downloaded QGIS 3.0 and gone through installation several times, but the program keeps crashing before it opens. Hopefully the copied report below helps. I'm looking forward to getting up and running with 3.0! Thanks for the help.

User Feedback

Report Details

Crash ID: 2da396b26f43211ca81fa880817113c91d7a7715

Stack Trace

RtlFreeHeap :
HeapFree :
free :
DllUnregisterServer :
DllUnregisterServer :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
DllGetClassObjectWOW :
DllGetClassObjectWOW :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
CLSIDFromString :
ObjectStublessClient6 :
CoCreateInstanceEx :
ObjectStublessClient32 :
SHParseDisplayName :
Ordinal866 :
ILSaveToStream :
ShellExecuteExW :
ShellExecuteExW :
ShellExecuteExW :
Ordinal860 :
ShellExecuteExW :
ExtractIconExW :
Ordinal865 :
Ordinal865 :
QWidgetPrivate::registerDropSite :
QStackedWidget::`default constructor closure' :
QInputDialog::getInteger :
QgsDataCollectionItem::iconDir :
QgsDirectoryItem::icon :
QgsBrowserModel::data :
QSortFilterProxyModel::data :
QModelIndex::data :
QStyledItemDelegate::initStyleOption :
QStyledItemDelegate::sizeHint :
QTreeView::indexRowSizeHint :
QTreeViewPrivate::itemHeight :
QTreeViewPrivate::updateScrollBars :
QTreeView::updateGeometries :
QAbstractItemView::doItemsLayout :
QTreeView::doItemsLayout :
QTreeView::sizeHintForColumn :
QHeaderView::resizeSections :
QHeaderView::sectionPosition :
QHeaderView::sectionViewportPosition :
QHeaderView::resizeSection :
QHeaderView::setStretchLastSection :
QgsBrowserDockWidget::showEvent :
QWidget::event :
QDockWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::show_helper :
QWidgetPrivate::showChildren :
QWidgetPrivate::show_helper :
QWidget::setVisible :
QgisApp::QgisApp :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.0-Girona
QGIS code revision: 001c80b0c3
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601


Related issues

Duplicates QGIS Application - Bug report #18260: qgis 3 crashes at start Closed 2018-02-28

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #18260

#2 Updated by Jürgen Fischer about 2 years ago

Also available in: Atom PDF