Feature request #8711

Please add decent North arrows

Added by Paolo Cavallini about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

We miss North arrows - please add some. Very important especially for print layouts.

NorthArrow_02.svg - North Arrow (new svg) (2.09 KB) Antonio Locandro, 05/08/2014 10:35 AM

NorthArrow_03.svg - North Arrow 3 (4.33 KB) Antonio Locandro, 05/08/2014 11:07 AM

NorthArrow_04.svg - Slight Variation (4.3 KB) Antonio Locandro, 05/08/2014 12:40 PM

NorthArrow_10.svg (1.61 KB) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_11.svg - 4 arrows (832 Bytes) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_12.svg - N-S arrow crossing 2 layers (2 KB) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_05.svg - Arrow + box with rounded borders (947 Bytes) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_06.svg - Arrow + box (900 Bytes) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_07.svg (1.3 KB) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_08.svg - Mushroom style (1.28 KB) Asier Sarasua, 05/09/2014 06:04 AM

NorthArrow_09.svg - Taj Mahal style (1.56 KB) Asier Sarasua, 05/09/2014 06:04 AM

WindRoses.tar.gz (88 KB) Loïc BARTOLETTI, 08/21/2014 09:08 PM

Associated revisions

Revision 06c0bd2b
Added by Nathan Woodrow over 3 years ago

Merge pull request #1371 from antoniolocandro/SVG-NORTH-ARROWS

North Arrows SVG - Fix #8711

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Target version set to Future Release - High Priority

#2 Updated by Antonio Locandro over 3 years ago

I guess adding arrows would mean generating SVG for them right? If someone can point me in the right direction and provide North Arrows they would want added to QGIS I could trace them in Inkscape maybe? I cant code too much but I can try this and see if it Works.

If this work I can start contributing other svg things like symbology etc.

Let me know either way

#3 Updated by Olivier Dalang over 3 years ago

Hi !

A google-images search on "north arrows" gives a lot of ideas.

Please add only very simple, clean and pro-looking arrows (as a reminder, those are the one we removed from 1.9 : https://www.dropbox.com/sh/zmmew0jlgbosoe4/4pfYqrzizI).

#4 Updated by Antonio Locandro over 3 years ago

Ok so I needed North Arrows and came back to this post where I was suppose to work on some.. anyway just to update I will create some North Arrows and Wind Roses, current ones are very few. Is there a download file of the old ones?

#5 Updated by Antonio Locandro over 3 years ago

This if my first attempt, any comments welcome. I successfully added initially the ability to change colors for the stroke using this tutorial http://www.sourcepole.com/svg-symbols-in-qgis-with-modifiable-colors, but there is no option to set param for text so I reverted

#6 Updated by Antonio Locandro over 3 years ago

Here is a second one, this one looks one way in Inkscape and browsers but for some reason QGIS renders it slightly different so any advice is welcome

BTW I am cleaning SVG files to reduce unused artifacts, I don't know if this makes a difference

#7 Updated by Antonio Locandro over 3 years ago

And a third one

#8 Updated by Tim Sutton over 3 years ago

Hi

Bear in mind using N limits the application to a subset of our users. We should at least provide variants which have no N so that they can be used in contexts where N is not the letter for North.

Nice to see some effort to improve the north arrow selection though.

Tim

#9 Updated by Jeff McKenna over 3 years ago

Hi everyone, I'd like to make a comment, but I'm a little scared/hesitant as I, am a long-time QGIS user (very long, hence the 0.x screen captures littered throughout the mapserver.org docs ha) but have not (yet) been involved with the development community. So please pardon me if I bring up an issue that has long been discussed (I fear this is the case). Here it goes...

Consistent feedback I get from students using the QGIS Print Composer is the confusion over adding a North arrow. Only me the teacher can figure out for them to Layout/Add Image/Search Directories. They them seem to lose any confidence in QGIS because there is a Layout/Add Arrow tool, that doesn't do what they assume it says it will.

Now I gather that the "Add Arrow" vs "Add North Arrow" is a localized issue. But how can we deal with this? I feel it is an important issue. Should the "Add Arrow" tool contain the same library of arrows as the Add Image tool does? Just wondering out loud.

Oh I did review the 3 arrow drafts, they look good Antonio!

-jeff

#10 Updated by Nyall Dawson over 3 years ago

Antonio Locandro - 02 and 04 look fantastic! 03 is a bit confusing though with it's two arrows in opposing directions.

#11 Updated by Matthias Kuhn over 3 years ago

Nice additions! Are you able to turn them into a PR?

Concerning #03
Maybe it could be improved by making the South arrow a bit lighter and the North arrow darker. The N text looks a bit skewed as well.

Jeff: There was also Issue #10207 which was closed as a duplicate of this and had the same contents as your comment. I wonder if this issue here also involves this. Nyall, any opinion?

#12 Updated by Giovanni Manghi over 3 years ago

Consistent feedback I get from students using the QGIS Print Composer is the confusion over adding a North arrow. Only me the teacher can figure out for them to Layout/Add Image/Search Directories. They them seem to lose any confidence in QGIS because there is a Layout/Add Arrow tool, that doesn't do what they assume it says it will.

having the svg symbols organized in categories, as in vector properties style dialog, would help?

#13 Updated by Jeff McKenna over 3 years ago

Giovanni - I am assuming you mean add categories to the Layout/Add Image/Search Directories? That helps, but, the reality is that users have no idea that they must 'add an image' in order to get a North arrow. The Layout/Add Arrow tool is the problem - could Layout/Add Arrow add a "Search Library" section in its "Item Properties", that uses the categories you refer to?

#14 Updated by Asier Sarasua over 3 years ago

Hi, I came across this issue when reading the developer mailing list and thought I could create some North arrows. I attach them to the issue.

#15 Updated by Anita Graser over 3 years ago

Thank you for you input Antonio and Asier!

Antonio, if you haven't created a pull request yet, please do so and add a link to the PR here. I think Tim also has a good point that it would be nice to have the north arrows with and without "N".

I hope I don't sound untactful, but for for me personally, Asier's north arrows are not yet of production quality. I like NorthArrow_10.svg but the others are still too rough in my opinion.

#16 Updated by Nathan Woodrow over 3 years ago

  • Status changed from Open to Closed

#17 Updated by Asier Sarasua over 3 years ago

@Anita No offence taken

#18 Updated by Loïc BARTOLETTI about 3 years ago

If you want, i created some north arrows with variants (inverse, without text, without internal outline). Here, only two arrows with variants.
You can combine a SVG with an other inversed (see grille2.shp SVG and SVG_i)

Also available in: Atom PDF