Bug report #1371

if I open a project file and the grass mapset is no longer there, qgis terminates

Added by arkygeek - about 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11431

Description

I rearranged my grassdata so the mapset was in a different location. When I tried opening the project file, it terminated instantly.

Associated revisions

Revision 37c73c1f
Added by Jürgen Fischer over 10 years ago

fix #1371

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 3b3556b0
Added by Jürgen Fischer over 10 years ago

fix #1371

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by grasslandtom - almost 11 years ago

hi arkygeek,

when I move a mapset I get an error message with the title "Uncatched fatal GRASS error" and a message like "LOCATION << $GISDBASE/$LOCATION/$MAPSET/$layername/$layername >> unavailable" with the first three variables denoting my respective GRASS gisenv variables and the following two the name of the first GRASS layer QGIS can not find.

Thus for me Ticket #1475 seems to be a duplicate of the one discussed here. Can you give it a try with QGIS 1.0.0 (I'm sorry, but I'm not able to try it with HEAD)?

(You can have a look at the mentioned ticket for a workaround, though I don't think you still need one)

Tom

#2 Updated by Paolo Cavallini over 10 years ago

It is indeed a duplicate of #1475; please check that ticket for additional info

#3 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 3b3556b0 (SVN r10581)

#4 Updated by Anonymous over 10 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF