Bug report #2230

Vertex markers are displayed in Print Composer

Added by dr - almost 10 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12290

Description

Vertex markers are displayed at Print Composer.

vertexes.jpg (97.3 KB) dr -, 2009-12-09 10:49 AM

patch_for_bug__2230.diff Magnifier (1.35 KB) sunilkcube -, 2011-03-25 03:54 AM

patch_for_bug__2230.txt Magnifier (1.35 KB) sunilkcube -, 2011-03-25 03:55 AM

History

#1 Updated by Giovanni Manghi almost 10 years ago

Just toggle editing off and then use the "update preview" in the composer. Not enough?

#2 Updated by dr - almost 10 years ago

Replying to [comment:1 lutra]:

Just toggle editing off and then use the "update preview" in the composer. Not enough?

Of course, but it's not user friendly. I guess that Print Composer need to do it.

#3 Updated by Giovanni Manghi almost 10 years ago

Replying to [comment:2 dr]:

I guess that Print Composer need to do it.

So, do you suggest the print composer to toggle editing off (with a warning? without?) if you are adding to the layout a map being edited?

I don't like the idea either, but it's just my opinion.

Nevertheless I see this more like a enhancement request or a minor bug, after all an there is an easy "workaround".

#4 Updated by dr - almost 10 years ago

Replying to [comment:3 lutra]:

Replying to [comment:2 dr]:

I guess that Print Composer need to do it.

So, do you suggest the print composer to toggle editing off (with a warning? without?) if you are adding to the layout a map being edited?

I don't like the idea either, but it's just my opinion.

Nevertheless I see this more like a enhancement request or a minor bug, after all an there is an easy "workaround".

I think that Print Composer need to turn off displaying vertex markers only, not to toggle editing off.

#5 Updated by sunilkcube - over 8 years ago

  • Status changed from Open to In Progress

#6 Updated by sunilkcube - over 8 years ago

Patch was added , Can anyone review and give comments here ?

#7 Updated by Marco Hugentobler over 8 years ago

  • Status changed from In Progress to Open

#8 Updated by Marco Hugentobler over 8 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Applied in 3d9e4144 (SVN r15607). Thanks!

#9 Updated by dr - over 8 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

In 3d9e4144 (SVN r15607) bug still present.

#10 Updated by Alexander Bruy over 8 years ago

Confirmed on Windows with QGIS 1.7 3d9e4144 (SVN r15607) from OSGeo4W. But on Linux with 35a5f55b (SVN r15608) all fine

#11 Updated by dr - over 8 years ago

Confirme bug in trunk 48900197 (SVN r15611) on Linux.

#12 Updated by Alexander Bruy over 8 years ago

Confirmed in 98d612f2 (SVN r15707) both Windows and Linux

#13 Updated by Alexander Bruy over 8 years ago

More info on this bug. If editing enabled before adding layers in Map Composer or in Overview Map then vertex markers are visible. But if I first add layer to the Overview Map or to Composer Map, and then enable editing - vertexes are not shown

#14 Updated by Alister Hood over 8 years ago

Do you guys really still have this problem?
It works fine for me now (in trunk on Windows).

#15 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#16 Updated by Giovanni Manghi almost 8 years ago

  • Pull Request or Patch supplied set to No
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

Alexander Bruy wrote:

But if I first add layer to the Overview Map or to Composer Map, and then enable editing - vertexes are not shown

But anyway when you will hit "update preview" in the compser the vertex markers will show.

Not sure what was the behavior before applying the patch, and what is the expected after applying it. Marco can you leave feedback?

#17 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#18 Updated by Alister Hood over 7 years ago

Alister Hood wrote:

Do you guys really still have this problem?
It works fine for me now (in trunk on Windows).

Actually, no. It doesn't work fine for me on either Windows or Linux. But the problem is only with layers using new symbology.

#19 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#20 Updated by Patrick Dunford almost 7 years ago

Don't think much of the comment about toggling the layers out of edit mode.

I often have 10 or 12 layers in editing all at once. it is very slow to turn them all off just to do one little piece of a map, and then go through and turn them all back on to edit again. Considering that Qgis takes a few seconds to toggle the editing state of each layer and you have to do each one in turn.

#21 Updated by Antonio Locandro over 6 years ago

Just had this problem yesterday on QGIS Master running on Ubuntu, took me at least an hour to figure out I had to toggle editing off. Although it could be seen as a minor problem this issue brings problems for me to suggest replacing other software with QGIS as other software have the ability to print without toggling editing.

#22 Updated by Jürgen Fischer over 5 years ago

  • Category changed from 33 to Map Composer/Printing

#23 Updated by Nyall Dawson over 5 years ago

I don't see this behavior in current master anymore. Can anyone confirm that this bug can be closed now?

#24 Updated by Nathan Woodrow over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Doesn't happen in master anymore.

Also available in: Atom PDF