Bug report #17262

Attribute table data entered text is obscured by the 'x' button

Added by Steve Lowman almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Attribute table
Affected QGIS version:2.18.13 Regression?:Yes
Operating System:W 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25160

Description

In QGIS 2.18 attribute table data entry, once the cell is full of text, the newly entered text is obscured at the right-hand end of the cell by the little 'x' button. This is quite off-putting for the user, who cannot see the text as it is typed in.

In QGIS 2.14, this problem was avoided by having a right margin in the cell while text was being entered. This right margin is not there in the 2.18 attribute table cell.

Comparison of attribute table data entry in QGIS 2.14 and 2.18.png - Images of data being entered into full cells in 2.14 and 2.18 attribute tables. (8.8 KB) Steve Lowman, 2017-10-09 11:56 AM

Bug_17262.mp4 - Demo showing characters being typed are obscured by the clear button (1.81 MB) Steve Lowman, 2017-10-16 08:28 PM


Related issues

Related to QGIS Application - Bug report #17289: Issue editing layers Closed 2017-10-16
Related to QGIS Application - Bug report #17187: Attribute Table refresh issue Closed 2017-09-24
Related to QGIS Application - Bug report #17280: When switch between filtered modes, the edited cells stop... Closed 2017-10-14

Associated revisions

Revision a7ffde6c
Added by Alessandro Pasotti over 2 years ago

[ui][bugfix] lineedit add margin for X icon

Fixes #17262

Needs backporting

Revision 106b8b63
Added by Alessandro Pasotti over 2 years ago

[ui][bugfix] lineedit add margin for X icon

Backported from master PR 5707

Fixes #17262

History

#1 Updated by Steve Lowman over 2 years ago

Attached video shows characters being typed are obscured by the 'clear' button, because there is no right margin on the cell while data is being typed in.

#2 Updated by Steve Lowman over 2 years ago

cross reference to bug 17289.
Both bugs are concerning data entry in attribute table 'table view'.
It may be efficient to fix both errors together.

Also 17187 and 17280, which is classed as High Priority. I think all four are closely related.

#3 Updated by Steve Lowman over 2 years ago

Okay, those other bugs are not directly related to this one.

However, I think this one should be classed as a Regression, because important functionality has been lost since the previous QGIS LTR releases.

#4 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

#5 Updated by Alessandro Pasotti over 2 years ago

#6 Updated by Alessandro Pasotti over 2 years ago

#7 Updated by Alessandro Pasotti over 2 years ago

  • Related to Bug report #17280: When switch between filtered modes, the edited cells stop updating themselves. added

#8 Updated by Alessandro Pasotti over 2 years ago

  • Assignee set to Alessandro Pasotti

#9 Updated by Alessandro Pasotti over 2 years ago

This also affects master

#10 Updated by Alessandro Pasotti over 2 years ago

  • Status changed from Open to In Progress

PR: https://github.com/qgis/QGIS/pull/5707
Backporting will follow.

#11 Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#12 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF