Bug report #17289

Issue editing layers

Added by Arthur Taute about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Editing
Affected QGIS version:2.18.13 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:25187

Description

I am having problems editing attribute data in 2.18.13 – when the layer is in edit mode - the edits typed into the attribute table are not shown untill after save and re-opening the table.
This happens with both PostGIS and shapefile layers.
Earlier versions of QGIS work fine on the same project.

Bug_17289_Feature1.mp4 - Attribute table - editing single row in Table View, nothing displays until save. (3.01 MB) Steve Lowman, 2017-10-16 08:22 PM

Bug_17289_Feature2.mp4 - Entering data into a second feature row in Table View (2.69 MB) Steve Lowman, 2017-10-16 08:23 PM


Related issues

Related to QGIS Application - Bug report #17262: Attribute table data entered text is obscured by the 'x' ... Closed 2017-10-09
Duplicates QGIS Application - Bug report #17187: Attribute Table refresh issue Closed 2017-09-24

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Subject changed from QGIS 2.18.13 to Issue editing layers
  • Status changed from Open to Feedback
  • Operating System deleted (MS)

Please use a descriptive title when filing issues, thanks!

Can you please add detailed steps (and data if necessary) on how replicate the issue, thanks!

#2 Updated by Steve Lowman almost 4 years ago

Please see attached mp4 video demonstrating some of the problem, with only one feature in the layer.
I will upload a second one to show how it behaves for the second feature digitised.

With only one feature in the layer, enter attributes into each cell, tabbing across from cell to cell.
You see the data being entered, but it disappears when you tab to the next cell.
Also, when you do a simple calculation, the result fails to display in the relevant cell.

Only on clicking Save, then the data items appear.
Not shown here, but sometimes not even the Save will make the data visible. Then you have to close and re-open the Attribute Table to see the entered data in the cells.

#3 Updated by Steve Lowman almost 4 years ago

Attached mp4 shows data being entered for a second feature.

This time, the data disappears on the first 'tab' but then reappears when I tab again, so the data entry is displayed one cell behind where it should be.
The result of the calculation is more consistently failing to display until Save is clicked.
However, I hear that it may display on scrolling if I had more features in the layer to scroll with.

#4 Updated by Steve Lowman almost 4 years ago

#17262.
Both bugs are concerning data entry in attribute table 'table view'.
It may be efficient to fix both errors together.

Also #17187 - This is a very similar bug, currently classed as High Priority, and it is actually shown in the mp4 videos entered here above.
Also #17280 - this is basically the same bug.

#5 Updated by Steve Lowman almost 4 years ago

I suggest the category should be 'Attribute Table', not 'Editing'.

#6 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

Duplicate of #17187

#7 Updated by Jürgen Fischer almost 4 years ago

#8 Updated by Jürgen Fischer almost 4 years ago

#9 Updated by Jürgen Fischer almost 4 years ago

#10 Updated by Alessandro Pasotti almost 4 years ago

  • Related to Bug report #17262: Attribute table data entered text is obscured by the 'x' button added

Also available in: Atom PDF