Feature request #9339

Do not print setting for composer layer

Added by James Harvey over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:17942

Description

It would be good to have a tick box on each layout composer item for "Do not print" layer. Like setting some layers in Illustrator documents to do not print. I sometimes use a referencing image underneath my map for layout positioning. It would be nice to keep it locked in the background and turned off and set via a "Do not print" layer so that it does not show on a Image/PDF export.

History

#1 Updated by Nathan Woodrow over 6 years ago

Have a look for a plugin called Layer Combinations. It will allow you to create combinations of layers which you can then set for a map frame in the composer. So you can have a combination with the base layer off and one with it on. Your main map stays as the one with it on but the composer map frame has the off one set.

#2 Updated by Nyall Dawson over 6 years ago

James - is this a duplicate of #4357? Does that match what you're after?

#3 Updated by James Harvey over 6 years ago

Yes similar to that item, but not just labels. Would be for objects like images placed and items like lines and other objects etc. that can be used as design placement guides.

#4 Updated by James Harvey over 6 years ago

At the moment I have a duplicate composer layout as a work around with the alignment image on. I delete the image used as a position guide when I want to export.

#5 Updated by Nyall Dawson almost 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Implemented in master

Also available in: Atom PDF