Bug report #9295

GetPrint causes segfault if HTML formatted text is used in the template

Added by Alessandro Pasotti almost 6 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:QGIS Server
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:Yes Copied to github as #:17904

Description

This bug was discussed at least in
http://lists.osgeo.org/pipermail/qgis-developer/2013-May/026269.html
but I couldn't find the related ticket, please mark as duplicate if it already exists.

The bug is still present in master.

While waiting for a fix we should document this issue as a known limitation.


Related issues

Related to QGIS Application - Bug report #9763: GetPrint segfault Closed 2014-03-11

History

#1 Updated by Alessandro Pasotti almost 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#2 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to High

#3 Updated by René-Luc ReLuc almost 6 years ago

The known limitation is that QGIS-Server needs a fake X server to render HTML in GetPrint.

We use it in production with getPrint, HTML and fake X server without crashes.

To avoid to use fake X server, QGIS has to use QtWebView headless. It's possible because PhantomJS do it.
http://phantomjs.org/
https://github.com/ariya/phantomjs/

#4 Updated by Alessandro Pasotti almost 6 years ago

I know that there are workarounds but it's still a serious bug.

This "known limitation" is not really "known" by most part of the users, AFAIK it isn't documented anywhere but in a few old emails, it should be clearly documented instead and we should try to find a system to avoid the crash when an X server isn't available, better serve a blank field instead.

If we cannot find a way to avoid the crash, as a last resource, we should add X to the package dependencies.

#5 Updated by aperi2007 - over 5 years ago

-1
To add dependencies
We cannot add x on pur server.
Contestually se font use the getprint .
IT is not a standard wms command
so many wms client dont support iT.
Ask a dependency forma a non standard command mean lost user.
+1 to add clearly to documentation.

#6 Updated by Paolo Cavallini over 5 years ago

Don't know if it's the same issue, but we're getting:

[Thu Jul 31 13:27:07.210983 2014] [fcgid:warn] [pid 5450] (104)Connection reset by peer: [client 127.0.0.1:46153] mod_fcgid: error reading data from FastCGI server
[Thu Jul 31 13:27:07.211444 2014] [core:error] [pid 5450] [client 127.0.0.1:46153] End of script output before headers: qgis_mapserv.fcgi

even after installing and configuring xvfb. This happens quite reliably when attempting to print a layout with layers present in the template legend, but switched off in the TOC.

#7 Updated by Giovanni Manghi over 4 years ago

see also #9763

#8 Updated by luca76 - about 4 years ago

see also #13285, comment of Giovanni Manghi explains a possible solution:

a solution is here (and I think is also in the manual)

http://www.itopen.it/qgis-server-setup-notes/

#9 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.0.1 to 2.18.4
  • Target version set to Version 2.18

Still pretty much the case in all QGIS Server installations on headless Linux Servers.

#10 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#11 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to Closed
  • Description updated (diff)
  • Resolution set to wontfix

Fixed in documentation.

Also available in: Atom PDF