Feature request #8884

Symbol too small in legend when map units are used

Added by Vincent Picavet about 4 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

When a symbol is defined with map units, it is sometimes shown in the legend at a very small scale, preventing to see the details.
If millimeters are used for symbol size, it is displayed in the legend at the right size.
A solution could be to used map units for the symbol display on the map, but fixed size for the symbol in the legend.

legenda.jpg (265 KB) michele zanolli, 07/01/2016 02:18 AM


Subtasks

Bug report #10049: toc: point symbols not visible if in map unitsRejected

History

#1 Updated by luca76 - over 3 years ago

Confirmed.

If I use millimeters, the symbols are visible, but when I use map-units they are just too small to see (even with a EYEGLASS :-) )

#2 Updated by michele zanolli over 1 year ago

The problem still persists...
And in QGIS 2.14, if you use -->Categorized<-- style and map units for size of point/svg symbols, the size of the symbol in the layer legend is totally out of control (see attached image)

#3 Updated by Reinhard Reiterer over 1 year ago

See also:

#14850 'Layers Panel' - Symbol size depends on zoom level
#13779 symbols not correctly clipped in map legend

#4 Updated by michele zanolli over 1 year ago

Thanks, I think that we can mark this ticket as duplicated (even if older)

#5 Updated by Nyall Dawson over 1 year ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF