Bug report #5590

Arrow in composer - "bounding box" corners

Added by Jonathan Moules over 7 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15167

Description

The four corners for the "bounding box" of the arrow you add in print composer aren't actually surrounding the arrow you add. The "bottom" ones are mid-way up the arrow.

Clipboard01.png (567 Bytes) Jonathan Moules, 2012-05-15 02:18 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Assignee set to Marco Hugentobler
  • Category set to 33
  • Status changed from Open to Feedback

I cannot confirm on master on Ubuntu. Can you please leave feeback and post a screenshot?

#2 Updated by Jonathan Moules over 7 years ago

Screenshot attached. 1.7.4 on Windows server 2008 r2

#3 Updated by Giovanni Manghi over 7 years ago

Ok I see, but I would say that this issue is related to #5588

#4 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Feedback to Open

#5 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#6 Updated by Giovanni Manghi about 6 years ago

  • Target version changed from Version 2.0.0 to 70
  • Affected QGIS version changed from 1.7.4 to 2.0.1
  • Assignee deleted (Marco Hugentobler)

#7 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from 70 to Future Release - High Priority

#8 Updated by Jürgen Fischer over 5 years ago

  • Category changed from 33 to Map Composer/Printing

#9 Updated by Médéric RIBREUX almost 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I can't reproduce it on QGIS 2.13 master. Can you confirm this bug is fixed (I think it is) ?

#10 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Feedback to Open

It's still an issue... not as bad as it used to be, but still needs addressing.

#11 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#12 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in layouts engine - no more arrow items! Now everything is done with the much improved polyline item.

Also available in: Atom PDF