Bug report #4628

Measure area - result varies with ellipsoidal toggling & with no. of vertices in polygon

Added by Steve Hartley almost 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:14529

Description

I'm running QGIS 1.7.2 on Win 2000.
Further to bug report no.4416.
This effect seems to occur whether starting with ellipsoidal on or off. The first area (i.e. after right click to finish sketched polygon) in "Total" box is roughly correct. Toggling ellipsoidal then changes "Total" to a reduced amount, toggling again changes "Total" to a slightly higher amount but doesn't return it to the first reading. The effect is more pronounced with fewer vertices in the sketched polygon. With 4 vertices the first toggling approximately halves "Total", and subsequent toggling changes it close to this halved quantity. With 3 vertices, the first toggling reduces it to 0.00, and further toggling still results in 0.00.

Associated revisions

Revision f1b58383
Added by Nathan Woodrow over 5 years ago

Merge pull request #1444 from avlisad/master

Improve mouse logic for measure tool. Fix #4628 Fix #10029

History

#1 Updated by Paolo Cavallini almost 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #4252

#2 Updated by Alister Hood almost 8 years ago

This and #4416 are duplicates of each other, but are completely different from #4252

Also available in: Atom PDF