Bug report #3762

"Cancel" does not revert a change between new and old symbology

Added by Alister Hood almost 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:13821

Description

(I'm setting this as "minor" since it isn't very important and the old symbology will be dropped soon I think. But I thought it should be reported anyway, just to be thorough.)

  1. open the Layer Properties for a vector layer
  2. click the button to switch between Old and New Symbology
  3. click "Yes"
  4. click "Cancel"
  5. open the Layer Properties again: the symbology is still set to what it was after step
  6. But when "Cancel" was clicked a normal user would have expected it to have reverted back to what it was originally.

FWIW I'm running r15740

History

#1 Updated by Jürgen Fischer almost 9 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

duplicate of #3761

#2 Updated by Alister Hood almost 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (duplicate)

No, not a duplicate. It is a different cancel button in a different dialogue (a sub-dialogue).

#3 Updated by Alister Hood almost 9 years ago

It is a different cancel button in a different dialogue (a sub-dialogue).

I mean #3761 is in a sub-dialogue of this one.

#4 Updated by Jürgen Fischer over 8 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)
  • Status changed from Feedback to Open

#5 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#6 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#7 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#8 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#9 Updated by Nyall Dawson over 4 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Old symbology is gone...

Also available in: Atom PDF