Bug report #3550

Labels scale dependency not saved

Added by andskog - over 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13610

Description

When applying scale dependent rendering on labels in a layers properties, this setting, when pressing Save As Default, is not recorded in the .QML file. Same thing when saving a project, label scale dependencies are left out from the project file.

History

#1 Updated by John Tull over 8 years ago

Also, the "display name" is not saved. I believe this is related, so adding it here.

#2 Updated by sunilkcube - over 8 years ago

  • Status changed from Open to In Progress

#3 Updated by sunilkcube - over 8 years ago

  • Status changed from In Progress to Closed
  • Resolution set to worksforme

Replying to andskog:
it is working for me. Can anyone conform this bug , if so can you list the steps ?

#4 Updated by sunilkcube - over 8 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Feedback

#5 Updated by sunilkcube - over 8 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

#6 Updated by Roger Diercks almost 8 years ago

I am experiencing the issue with layer label scale dependencies not being saved to the project file in both 1.7.1. and 1.7.2 running Ubuntu 11.04. It works as intended in 1.7.1 in Windows 7.

#7 Updated by Giovanni Manghi almost 8 years ago

  • Assignee deleted (sunilkcube -)
  • Pull Request or Patch supplied set to No

Roger Diercks wrote:

I am experiencing the issue with layer label scale dependencies not being saved to the project file in both 1.7.1. and 1.7.2 running Ubuntu 11.04. It works as intended in 1.7.1 in Windows 7.

it works for me under Ubuntu 11.10 with qgis 1.7.2

#8 Updated by cdavilam - over 7 years ago

  • OS version set to debian squeeze
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Operating System changed from Windows to Linux
  • Target version changed from Version 1.7.0 to Version 1.8.0
  • Status changed from Closed to Reopened

Confirmed on debian squeeze, using master (1.9.90-Alpha rev a1ac714), 1.7.3 and 1.7.4.
Steps:
Load some layers into a project, label one of them by a given field and active "Use scale dependent rendering". Save project and exit QGIS. When you reopen the project, scale dependent rendering has gone and labels are shown at all zoom levels.

#9 Updated by Dmitry D over 7 years ago

Confirmed on Windows 7 32 bit, QGIS 1.7.4 411aff6, and on Android 3.2 QGIS QGIS 1.9.90 a8cf00d

I've inserted specific instructions into qgs-file manually.
Original string:
<maplayer minimumScale="0" maximumScale="1e+08" geometry="Polygon" type="vector" hasScaleBasedVisibilityFlag="0">

Manually modified string:
<maplayer minimumScale="1" maximumScale="1e+08" minLabelScale="1" maxLabelScale="1e+05" geometry="Polygon" type="vector" hasScaleBasedVisibilityFlag="1" scaleBasedLabelVisibilityFlag="1" >

I've opened modified project - everything was OK, label only within 100 000 scale, but when I tried to close project, system asked to save changes (I've changed nothing). Positive answer caused following changes to the above mentioned string:

<maplayer minimumScale="1" maximumScale="1e+08" geometry="Polygon" type="vector" hasScaleBasedVisibilityFlag="1">

#10 Updated by Alister Hood over 7 years ago

  • Status info deleted (0)
  • Category changed from Symbology to Labelling
  • Target version deleted (Version 1.8.0)
  • Operating System changed from Linux to All
  • OS version deleted (debian squeeze)

If I read correctly, this is a problem with "old labelling", so will not be applicable when "old labelling" is removed.

#11 Updated by Alister Hood over 7 years ago

  • Resolution deleted (worksforme)

#12 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#13 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to fixed
  • Status changed from Reopened to Closed

Alister Hood wrote:

If I read correctly, this is a problem with "old labelling", so will not be applicable when "old labelling" is removed.

anyway seems really fixed in master.

#14 Updated by Willem Buitendyk over 6 years ago

  • Status changed from Closed to Reopened

I am experiencing this problem with 1.8 on all platforms (Mac, Linux, Win7). I have 3 WFS layers only. Saving or settings as default does nothing upon exiting and reopening.

#15 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Reopened to Closed

Willem Buitendyk wrote:

I am experiencing this problem with 1.8 on all platforms (Mac, Linux, Win7). I have 3 WFS layers only. Saving or settings as default does nothing upon exiting and reopening.

this issue has been fixed in qgis master, aka 2.0. There are no backports. Cheers!

Also available in: Atom PDF