Bug report #206

Various dialog boxes don't remember their location and size

Added by Gavin Macaulay - about 13 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:10265

Description

Quite a few of the dialog boxes in qgis don't remember their location and size - I think that they should. Culprits include:

  • line and area measure
  • help viewer
  • all of the plugin dialogs
  • attribute table
  • bookmarks

The identify results, the qgis window, the printer composer do remember their size and position.

History

#1 Updated by Tom Elwertowski over 12 years ago

The fix for #440 can be added to these too.

#2 Updated by Tim Sutton about 12 years ago

Changed to minor under the following scheme:
  • blocker - bugs that should block the release. Since we are going to release pretty much 'come what may' I would like no bugs
  • allocated to this category without consultation with me and / or PSC
  • critical - bugs that cause the application to crash or corrupt data
  • major - application features that do not function at all
  • minor - features that function but imerfectly e.g. labels placing incorrectly
  • trivial - gui useability issues or small issues with the documentation, install notes etc.

#3 Updated by Brendon Wolff-Piggott - almost 11 years ago

Replying to [comment:2 timlinux]:

Changed to minor under the following scheme:
  • blocker - bugs that should block the release. Since we are going to release pretty much 'come what may' I would like no bugs
  • allocated to this category without consultation with me and / or PSC
  • critical - bugs that cause the application to crash or corrupt data
  • major - application features that do not function at all
  • minor - features that function but imerfectly e.g. labels placing incorrectly
  • trivial - gui useability issues or small issues with the documentation, install notes etc.

================================
Checked this on QGIS 1.0.0 Preview II. Confirmed behaviour fixed for:
1. Line and Area Measure
2. Attribute Table
3. Help Contents

Dialogs that still had this problem:
1. New Bookmark
2. Show Bookmarks
3. Plug-ins:
All Tested - from "Add WFS" to "Georeferencer"

#4 Updated by Brendon Wolff-Piggott - almost 11 years ago

Replying to [comment:3 brendonwp]:

Replying to [comment:2 timlinux]:

Changed to minor under the following scheme:
  • blocker - bugs that should block the release. Since we are going to release pretty much 'come what may' I would like no bugs
  • allocated to this category without consultation with me and / or PSC
  • critical - bugs that cause the application to crash or corrupt data
  • major - application features that do not function at all
  • minor - features that function but imerfectly e.g. labels placing incorrectly
  • trivial - gui useability issues or small issues with the documentation, install notes etc.

================================

Checked this on QGIS 1.0.0 Preview II. Confirmed behaviour fixed for:
1. Line and Area Measure
2. Attribute Table
3. Help Contents

Dialogs that still had this problem:
1. New Bookmark
2. Show Bookmarks
3. Plug-ins:
All Tested - from "Add WFS" to "Georeferencer"

#5 Updated by Giovanni Manghi about 10 years ago

Made a few tests with QGis 1.2 (rev. 11019):

  • line and area measure -> ok
  • help viewer -> now a html page?
  • all of the plugin dialogs -> tested core plugins, not ok
  • attribute table -> ok
  • bookmarks -> size ok, position not ok
  • identify results -> ok
  • print composer -> ok
  • new bookmark -> not ok
  • open project -> not ok
  • save project as -> not ok
  • add vector, raster, postgis, spatialite, wms -> not ok
  • gps tools -> not ok
  • new vector -> not ok
  • open mapset -> ok
  • new mapset -> size ok, position not ok
  • add grass vector -> ok
  • add grass raster -> ok
  • new grass vector -> not ok
  • grass toolbox -> size ok, position not ok
  • edit current grass region -> ok

#6 Updated by Giovanni Manghi almost 8 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (Tom Elwertowski)

see also #4133

#7 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#8 Updated by Alexander Bruy over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

GPSTools plugin dialog fixed in 1c3117e3cb

#9 Updated by Alexander Bruy over 7 years ago

Most core plugins fixed in 2e7867a14e

#10 Updated by Alexander Bruy over 7 years ago

03d3bed548 fixes WFS dialog

#11 Updated by Alexander Bruy over 7 years ago

And 27249d88d1 fixes almost all core dialogs.

#12 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#13 Updated by Giovanni Manghi about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0
  • Operating System deleted (All)
  • Status info deleted (0)

add to the list:

vector options -> style -> change -> svg fill -> ...

that is the dialog that allows the user to pick a svg file that is not part of the svg QGIS library.

#14 Updated by Nathan Woodrow over 5 years ago

  • Tag set to easy

#15 Updated by Nathan Woodrow over 5 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

I have just recently gone though and implemented this for a lot of dialogs. Please test and reopen if there are some that have been missed.

Also available in: Atom PDF