Bug report #17327

Sorting of input layer Layers in Processing "multiple inputs" widgets

Added by Hans Fuchs about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.18.13 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25225

Description

In Processing Tool Box Modules such as Gdal>Misc>Merge, Gdal>Misc>Build Virtual Raster or OTB >Image Manipulation>Images Concatenation the order of loaded raster layers in the Layers Panel is not correctly transferred to the input images layers list (Mutiple selection) of the Processing Toolbox modules. The order of the layer is random and cannot be changed which makes these modules useless.

OSGeo4W QGIS 2.18.13


Related issues

Related to QGIS Application - Bug report #17127: Control order by which bands are stacked Closed 2017-09-12
Duplicated by QGIS Application - Feature request #17321: Sorting of layers in Processing "multiple input" widget Closed 2017-10-23

Associated revisions

Revision a9d820d3
Added by Nyall Dawson over 2 years ago

[processing] Don't overwrite rows when reordering in multi input
dialog

Refs #17327

Revision 6524cacd
Added by Nyall Dawson over 2 years ago

[processing] Don't overwrite rows when reordering in multi input
dialog

Refs #17327

(cherry-picked from a9d820d37)

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Category changed from Processing/GUI to Processing/Core
  • Subject changed from Sorting of Raster Layers in Processing Toolbox Modules to Sorting of input layer Layers in Processing "multiple inputs" widgets

This is pretty much duplicate of #17127 but this is more general.

Is indeed a real issue: in the multiple inputs widgets there is the need to allow sorting of layers and the sorted list then transferred as it is in the command being executed.

#2 Updated by Nyall Dawson about 3 years ago

  • Status changed from Open to Feedback

This should be fixed in master - can you confirm?

#3 Updated by Jürgen Fischer about 3 years ago

#4 Updated by Alexander Bruy about 3 years ago

#5 Updated by Giovanni Manghi about 3 years ago

Nyall Dawson wrote:

This should be fixed in master - can you confirm?

I just checked: is not completely fixed. In the multiple input widget you can as a fact d&d the layers to reorder them but:

  • having also arrows would be more intuitive for the users
  • d&d only kind of works: if in the list you d&d a layer over the name of another then one of the two is removed from the list

#6 Updated by Alister Hood almost 3 years ago

Should we change the status of this to "open", or open a new ticket (or close - I haven't checked if Giovanni's last point is still a problem)?

#7 Updated by Alister Hood almost 3 years ago

Hi guys, if you are using outputs from several uses of another algorithm (perhaps a smoothing algorithm or gdalwarp), and you drag them around to change the order, is there any way of knowing which one is which?
See #17928

#8 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed
  • having also arrows would be more intuitive for the users
  • d&d only kind of works: if in the list you d&d a layer over the name of another then one of the two is removed from the list

I guess the arrows thing should be a feature request, the second issue seems fixed.

Also available in: Atom PDF