Bug report #10765

Actions on layer don't use field values

Added by Aleksander Novoselov over 5 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Forms
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19148

Description

if you call the action on the edit form

ping -c 5 [% "ip" %]

action is taken - the variable "ip" is not sent

Starting ping -c 5 ...
Usage: ping [-aAbBdDfhLnOqrRUvV] [-c count] [-i interval] [-I interface] [-m mark] [-M pmtudisc_option] [-l preload] [-p pattern] [-Q tos] [-s packetsize] [-S sndbuf] [-t ttl] [-T timestamp_option] [-w deadline] [-W timeout] [hop1 ...] destination
Done

ip

form.png (29.7 KB) Aleksander Novoselov, 2014-07-01 04:18 AM

History

#1 Updated by Paolo Cavallini over 5 years ago

  • Subject changed from Actoins on layer not work. to Actions on layer not work.

#2 Updated by Nathan Woodrow over 5 years ago

  • Tag set to actions
  • Target version set to Future Release - High Priority
  • Category set to Forms
  • Subject changed from Actions on layer not work. to Actions on layer don't use field values

#3 Updated by Aleksander Novoselov over 5 years ago

#4 Updated by Alexander Novoselov about 5 years ago

2.5.0-Master

This bug http://youtu.be/WBpTQRh6JCY

#5 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #14683

Also available in: Atom PDF