Bug report #10087

"else" rules are broken in master

Added by Nyall Dawson over 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:High
Assignee:Nathan Woodrow
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18555

Description

The "else" rule which was added in 2.2 is broken in current master. It's now reported as an invalid expression and doesn't evaluate correctly.

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Category set to Symbology

#2 Updated by Nathan Woodrow over 5 years ago

  • Target version set to Future Release - Nice to have
  • Priority changed from Severe/Regression to High

This is mainly just a failing of the UI. You can't use the expression builder to add a ELSE rule as ELSE is a special rule based rendering thing.

#3 Updated by Jürgen Fischer over 5 years ago

  • Category changed from Symbology to GUI

#4 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #8591

Also available in: Atom PDF