Bug report #9502

Reshape Tool quits working

Added by Samuel Grant about 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:18093

Description

When editing a polygon, the Reshape tool works for a while, about 20 edits, the stops working on that shape. It will work on another shape, but stops after a few edits.

History

#1 Updated by Paolo Cavallini about 6 years ago

  • Subject changed from Rehape Tool quits working to Reshape Tool quits working

#2 Updated by Samuel Grant about 6 years ago

Also in QGIS version 2.1.0....

#3 Updated by Giovanni Manghi about 6 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • Target version set to Version 2.2
  • Priority changed from High to Normal
  • Category set to Digitising

#4 Updated by Giovanni Manghi about 6 years ago

I ca replicate the issue (even with mush less edits with the reshape tool). What is worst is that in some case the tool stops to work at all in that specific feature, even of reloading the vector (the geometry and the vector is error free).

#5 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#6 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

I haven't been able to reproduce this since 2.10 - please confirm whether this issue is fixed for you

#7 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closing for lack of feedback. Reopen if necessary.

Also available in: Atom PDF