Bug report #8538

SVG symbols greyed out

Added by Gavin Fleming over 7 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17289

Description

In the layer style tab and elsewhere where available SVG symbols are shown,many of them appear greyed out. You can just see them. If you click on them they are still selected and used but it is hard to see them in the first place. This is just an issue on Windows, not Linux.

Associated revisions

Revision 16f700a5
Added by Nyall Dawson about 5 years ago

Fix svg outline widths are incorrectly scaled (fix #11522)

SVG outline width sizes were not correctly calculated, and were
set to a constant value regardless of the rendered size of the svg
image. This meant that:
1. the rendered outline width was effectively randomly scaled
2. the width would change as the symbol size was modified

This change has some large flow on effects, eg:

- the large outline widths required to render an outline in <2.12
will now be drawn in their correct sizes, eg massive outlines. Projects
will need to be updated to reflect this.
- the default outline width set for the provided svg symbols (1 mm)
is much too large, so the symbols look bad with the default width.
This size needs to be modified in all the (~300 svg marker images)
- On the plus side, the long standing issue where most of the svg
symbols were rendered with white fill on white background and an
almost invisible black border is now fixed (refs #10908, #8538)

History

#1 Updated by Larry Shaffer over 7 years ago

  • Category set to Symbology

Hi,

This is a known graphical bug in the way Windows renders (or doesn't in this case) SVGs. The new symbols are intended to be grey. Then, they can be layered on top of either a white or black background, and still initially look OK on both.

Any of those new 'grey' symbols are also SVG parameter-enabled, so you should be able to change their fill or stroke color (where appropriate) in the symbology dialog.

I'm leaving the issue open, as the Windows rendering is still an bug (though don't know if it can be fixed).

#2 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Going to flag this as a duplicated of #10908 to keep discussion in the one report

Also available in: Atom PDF