Bug report #8506

In the Label Section- option Type case - Capitalize first letter don't work

Added by aperi2007 - over 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Larry Shaffer
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17266

Description

as repeorted.

In the label properties, when choose to set the "Type case" ,
the option "Capitalize first letters" don't work, it return always the all uppercase letters.

Instead the option "all lowercase" work correctly.

Andrea.

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Assignee set to Larry Shaffer
  • Status changed from Open to Feedback

just tested on qgis master and cannot confirm this issue.

#2 Updated by aperi2007 - over 6 years ago

  • Status changed from Feedback to Closed

Ok,
more probably is a question of my windows.

Also I found an easy workaround defining on my dbms a view with case transformation.

So I close the ticket.

Thx,

#3 Updated by belg4mit - about 6 years ago

  • Status changed from Closed to Reopened

This was closed prematurely, it does not work as advertised. The problem is that the function assumes the input is already lowercase, whereas official sources e.g; MassGIS; may store text as all uppercase. The solution is to lc() the string before ucfirst().

#4 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Reopened to Closed

Duplicate of #7724

Also available in: Atom PDF