Bug report #7724

Label type cases do not alter output if label text is upper case

Added by Anita Graser over 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:16632

Description

To replicate, use the airport.shp from QGIS sample data. The name attribute texts are all upper case. Changing the label type case to "mixed case" or "title" does not create mixed case. Selecting "all lowercase" works and changes the output.


Related issues

Related to QGIS Application - Feature request #7611: Title case option which also operates on uppercase words Reopened 2013-04-14

History

#1 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#2 Updated by Anita Graser over 5 years ago

This bug is still around. "Capitalize first letter" does not change the label if it's all upper case. The work-around is to use the title() function in label expression.

#3 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #7611

Also available in: Atom PDF