Bug report #8423

QGIS interface stops updating

Added by Jonathan Moules over 7 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:17192

Description

QGIS weekly a13cdf8 - windows 7 x64

See the attached screenshots. When I resize QGIS, or change the window layer (i.e., open the log messages) it mangles the interface which stops rendering.

This only seems to happen when there is a reasonably large dataset loaded. I.e. a 20MB shapefile (image 4), or a several hundred MB SpatiaLite database.

Clipboard01.png (67.1 KB) Jonathan Moules, 2013-08-08 12:38 AM

Clipboard02.png (132 KB) Jonathan Moules, 2013-08-08 12:38 AM

Clipboard03.png (91.6 KB) Jonathan Moules, 2013-08-08 12:38 AM

Clipboard04.png (125 KB) Jonathan Moules, 2013-08-08 12:38 AM

resize.mp4 (1.76 MB) Giovanni Manghi, 2013-08-08 11:25 AM

toolbars.mp4 (1.74 MB) Giovanni Manghi, 2013-08-08 11:25 AM

Clipboard01.jpg - processing toolbox issue in comment 4 (96.7 KB) Jonathan Moules, 2013-09-26 08:53 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Operating System set to Windows
  • File resize.mp4 added
  • File toolbars.mp4 added
  • Category set to GUI
  • Priority changed from Normal to Low

I have seen it too but just on Windows and in a less severe way (see attached screencast), maybe this a video drivers issue after all.

#2 Updated by Jonathan Moules over 7 years ago

The graphics card is two "NVIDIA NVS 310".
Driver: NVIDIA Version 311.35

I've not seen this with any other application on this machine.

#3 Updated by Nathan Woodrow over 7 years ago

This seems to be a Qt thing on some Windows machines. I get it here too.

#4 Updated by Jonathan Moules about 7 years ago

Possibly the same issue, but in 2.0.1, every time I make the processing toolbox less wide, the window fails to update properly and I get a grey bar in the map window where the processing box was before.

#5 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

Is this still an issue with current supported releases?

#6 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF