Bug report #8144

labels data defined rotation does not work if data defined position is set + label rotation tool does not work if data defined position is not defined

Added by Giovanni Manghi over 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Larry Shaffer
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16972

Description

enable data defined rotation -> ok

then

enable data defined position -> labels become horizontal

then

move manually one label -> label is rotated

It is not a regression as in 1.8 there was a similar issue, it is anyway or a bug or a not intuitive way to work, user side obviously :)

Is there anyway to have all the labels automatically rotated after enabling the data defined position? if yes, is this case documented?

cheers!

History

#1 Updated by Paolo Cavallini over 6 years ago

  • Subject changed from labels data defined rotation does not work if data defined poistion is set(?) to labels data defined rotation does not work if data defined position is set(?)

#2 Updated by Giovanni Manghi over 5 years ago

  • Target version set to Future Release - High Priority
  • Subject changed from labels data defined rotation does not work if data defined position is set(?) to labels data defined rotation does not work if data defined position is set
  • Priority changed from Normal to High

another consequence of this issue is that without defining the data defined position for labels the labels are correctly rotated but the rotation tool does not work.

#3 Updated by Giovanni Manghi over 5 years ago

  • Subject changed from labels data defined rotation does not work if data defined position is set to labels data defined rotation does not work if data defined position is set + label rotation tool does not work if data defined position is not defined

#4 Updated by Giovanni Manghi over 5 years ago

  • Assignee set to Larry Shaffer

#5 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

I can't reproduce this - is it still an issue?

#6 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF