Bug report #7890

Composer layer transparency not respected in legend

Added by John Tull over 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16763

Description

Layer transparency applied under "Layer rendering" is not respected in composer legends. Instead, layers show the transparency of symbol-level transparency settings. So if you don't set transparency in the symbol properties, it is not correct in the composer legend.

transparency_alpha_channel_01.PNG - setting grid colors alpha channel transparency (211 KB) Miroslav Umlauf, 2014-08-01 04:39 AM

transparency_alpha_channel_02.PNG - grid colors in the legend (22.5 KB) Miroslav Umlauf, 2014-08-01 04:39 AM

transparency_global_01.PNG - setting global transparency (102 KB) Miroslav Umlauf, 2014-08-01 04:39 AM

transparency_global_02.PNG - grid colors in the new legend (13.9 KB) Miroslav Umlauf, 2014-08-01 04:39 AM

transparency_global_03.PNG - grid colors in the legend after save and reopen (12.5 KB) Miroslav Umlauf, 2014-08-01 04:39 AM

transparency_bug.png - thinning when using transparency (81 KB) Miroslav Umlauf, 2014-08-13 10:54 PM

Associated revisions

Revision da5215d3
Added by Nyall Dawson over 5 years ago

[composer] Respect layer transparency when drawing legend items (fix #7890)

History

#1 Updated by Nyall Dawson over 6 years ago

  • Assignee set to Nyall Dawson

#2 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#3 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

#4 Updated by Miroslav Umlauf over 5 years ago

  • Status changed from Closed to Reopened

Sorry to reopen this but the same problem is with grid layers. Symbols in layer list and print composer legend don't respect (global) transparency settings at all.

#5 Updated by Miroslav Umlauf over 5 years ago

  • Status changed from Reopened to Closed

Oh, sorry. I just found out it is already done in master also for grids in composer. But if you save project, close it and open it again the legend is without transparency settings. Also for raster the legend is not respecting color alpha channel (I thought I could use it as workaround but nope).

#6 Updated by Miroslav Umlauf over 5 years ago

  • Status changed from Closed to Reopened

So opening it again with these:
1. layer transparency for grid lost when saved and reopen project
2. alpha channel of grid colors not respected by legend at all

(both works fine for vector layers)

#7 Updated by Nyall Dawson over 5 years ago

  • Status changed from Reopened to Feedback

Sorry, I don't understand - what do you mean by grids? These aren't shown in the legend at all, and like you've noticed the issue with grid transparency not saving is solved in master and backported to 2.4 already.

#8 Updated by Miroslav Umlauf over 5 years ago

I hope this help to understand:

transparency_alpha_channel_01 - setting grid colors alpha channel transparency - transparency ok in layer list
transparency_alpha_channel_02 - grid colors in the legend - in the legend list ok, no transparency on the canvas

transparency_global_01 - setting global transparency - no transparency in the layer list
transparency_global_02 - grid colors in the legend - no transparency in the layer list, ok on the canvas
transparency_global_03 - grid colors in the legend after save and reopen - no transparency in the layer list, no transparency on the canvas

All screens form latest 2.5 Master.

#9 Updated by Miroslav Umlauf over 5 years ago

Also when using line pattern fill in combination with transparency there is bug in Export as image / Export as PDF. Seems like line pattern fill is rendered in significantly higher resolution making lines very thin (only in the legend, in map frame it is ok)

#10 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Open
  • Operating System deleted (All)

#11 Updated by Nyall Dawson about 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Seems to be fixed in master following Martin's recent legend refactoring work.

Also available in: Atom PDF