Bug report #7863

Loading color ramp per column

Added by Darius dela Cruz about 7 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:16738

Description

Dear QGIS,

I am using QGIS for Malaria Program here in the Philippines and I can say that kudos to you guys as this application is helping save lives!

In the 1.7.0-Wroclaw version of the project, I can display Malaria cases per year in a column in the attribute table. To go from one column (year) to another, I only need to load a saved color ramp once and change the column (year).

In current version of QGIS (1.8.0-Lisboa), I needed to define the color ramp for each year. I tried loading a saved color ramp but it will only return to the specific column (year) and reset once I enter the new column. What I did is to save the color ramp for each year and load it whenever I need to display a specific column.

See the project at this link:https://www.yousendit.com/download/WFJVclVBTXY5eFdybHNUQw

See also the attached screenshots.

What to do? Please help.

reset_1.png - screenshot (262 KB) Darius dela Cruz, 2013-05-19 11:50 PM

reset_2.png - screenshot (262 KB) Darius dela Cruz, 2013-05-19 11:50 PM

History

#1 Updated by Nathan Woodrow about 7 years ago

This would be because the classification changes automatically. It was something that I added a while ago, but it has been requested a few time there it be made a switch. I'll see what can be done.

#2 Updated by Nyall Dawson almost 6 years ago

  • Category deleted (Map Composer/Printing)

#3 Updated by Jürgen Fischer almost 6 years ago

  • Category set to Symbology

#4 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#5 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

Please test with a recent QGIS release (2.18 or 3), if the issue/request is still valid change the affected version accordingly, if is fixed/implemented then close the ticket. Thanks!

#6 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Closed
  • Description updated (diff)
  • Resolution set to not reproducable

Closing for lack of feedback.

Also available in: Atom PDF