Bug report #7842

layer properties / graduated / quantile / range ... sorting

Added by robert kalasek over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16724

Description

i am using a shp and a joined dbf-table with some demographic data

style: graduated
Column: a real 19/11 field from the joined dbf-table
value range of the data: 0.000 - 646.4222

classification of that column results in a wrong set of class braekes (see bug descriptin of "Bug #7841")
lower value of the classification starts at 5.000 instead of 0.000

my personal workaround: adding a class from 0.000 to 5.000

sorting of the resulting classification by clicking into "Range" returns an incorrect result ... see attached image

classification_range_sorting_error.png (38.2 KB) robert kalasek, 2013-05-16 03:33 AM

History

#1 Updated by Nathan Woodrow over 7 years ago

Have you tested the latest dev build?

#2 Updated by Giovanni Manghi over 7 years ago

  • Affected QGIS version changed from master to 1.8.0
  • Status changed from Open to Feedback
  • Category set to Symbology

Please try QGIS master, it should work fine... except for #7843

#3 Updated by robert kalasek over 7 years ago

Giovanni Manghi wrote:

Please try QGIS master, it should work fine... except for #7843

works fine in qgis master ...
my problem is that i have to do a lecture for students with 1.8. ... since that version is installt in our computer labratory

thx for the information anyway
and 1.9 looks really fine !!!

#4 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

works fine in qgis master ...
my problem is that i have to do a lecture for students with 1.8. ... since that version is installt in our computer labratory

you can show both the bug and also the fix, and so show that qgis is a quite dynamic project :)

cheers!

Also available in: Atom PDF