Bug report #7841

layer properties / graduated / quantile / classification error

Added by robert kalasek over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16723

Description

i am using a shp and a joined dbf-table with some demographic data

calculation of class breakes with style = graduated returns wrong breake values.
see attached *.png

the value-range within the field BEV91_P_H is from 0.000 to 646.4222
type of the field is real / 19 / 11

lower value of the first class starts with 5.00 instead of 0.00
either this breake value is wrong
or a class with breaks 0.000 - 5.000 is missing

... consequently the objects with values < 5.0 are missing in the map display.

this problem was already existing in 1.7 !
which is remarkable since classification is a key issue of cartography within a gis tool

classification_error.png (380 KB) robert kalasek, 2013-05-16 03:25 AM

History

#1 Updated by Nathan Woodrow over 7 years ago

Have you tested the latest dev build.

#2 Updated by Giovanni Manghi over 7 years ago

  • Affected QGIS version changed from master to 1.8.0
  • Category set to Symbology

Nathan Woodrow wrote:

Have you tested the latest dev build.

it seems really to work fine on master, please test and report back.

#3 Updated by robert kalasek over 7 years ago

also this one - no problem in qgis master !
(like #7842)

just a remark: the problem obviously did only occur with data from joined tables.
as soo as i saved the layer incl. the joined data to a new shp erverything was ok with the classification.

nice idea to demonstrate the potential of non commercial software ...

thx again

#4 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Also available in: Atom PDF