Bug report #7256

Calculation of graduated symbology breaks is broken in master

Added by Nyall Dawson over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16277

Description

Currently the calculation of Standard Deviation, Quantile and Natural Breaks is broken in master (probably since the introduction of the new vector API).

This is caused by qgsgraduatedsymbolrendererv2.cpp line 804, where

setSubsetOfAttributes( QgsAttributeList() )

should be

setSubsetOfAttributes( lst )

Associated revisions

Revision 54f3e0a4
Added by Nathan Woodrow over 8 years ago

Merge pull request #449 from nyalldawson/grad_fixes

Fix calculation of graduated symbology breaks (Fix #7256)

History

#1 Updated by Nyall Dawson over 8 years ago

Attached pull request fixes break calculation:

https://github.com/qgis/Quantum-GIS/pull/449

#2 Updated by Nathan Woodrow over 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF