Bug report #449

WinQGIS: wrong interactive measures

Added by Redmine Admin almost 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Magnus Homann
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10508

Description

The plugin to measure areas and length doesn't work well

History

#1 Updated by Gavin Macaulay - almost 14 years ago

We really need more details on your problem to have a chance of fixing it.

#2 Updated by anonymous - almost 14 years ago

The results are not correct and the value changes widely (without any apparent logic) if I make slight mouse movements. This only in the Windows version.

#3 Updated by Gavin Macaulay - almost 14 years ago

I have see this happen when the data is in a projected coordinate system, but qgis thinks that it is in lat/long. This happens when qgis's default coordinate system is lat/long, and the loaded file has no associated projection information.

#4 Updated by Gavin Macaulay - almost 14 years ago

Qgis now checks for the mismatched projection problem and warns the user, and suggests a solution (set an appropriate projection for the map using the Settings:Project Properties dialog).

Please try the next available version of qgis and see if this helps.

#5 Updated by Magnus Homann almost 14 years ago

  • Status changed from Open to In Progress

What is the layer source projection?
What is the projects projection?
Is projection turned on?
Please attach your test layer, if possible.

#6 Updated by Magnus Homann almost 14 years ago

  • Status changed from In Progress to Closed
  • Resolution set to fixed

Worksforme in 0.9 on win32. If any more info is available, I'm glad to re-open (see above).

#7 Updated by Anonymous over 11 years ago

Milestone Version 0.9 deleted

Also available in: Atom PDF