Bug report #7004

Custom positioning of Layers panel

Added by Patrick Dunford almost 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16105

Description

I prefer to have the Layers panel on the right hand side of the main window instead of its default position on the left. Qgis does a good job of remembering this position the next time I start up.

However if I open a project with the Layers panel docked on the right hand side, the following problems are observed:
  • All the layers in the project are disabled unless I check the "Control rendering order" box below the panel.
  • All the layers appear in order but their groups are all missing
  • Right clicking anywhere in the Layers panel is disabled.

The only fix for this problem is to undock the layers panel, dock it to the left then it magically starts working normally. Then undock it again and dock it to the right side. Then it keeps working just as if it were on the left.

History

#1 Updated by Nathan Woodrow almost 8 years ago

I can't confirm that here on Windows or Linux. Can you test a nighly build using the OSGeo4W install because the Control rendering order tickbox is now gone from that panel.

#2 Updated by Patrick Dunford almost 8 years ago

The problem is that so far (testing 1.8.0) I haven't worked out yet how to show this up consistently.

#3 Updated by Giovanni Manghi almost 8 years ago

Patrick Dunford wrote:

The problem is that so far (testing 1.8.0)

you should test qgis-master anyway.

#4 Updated by Patrick Dunford almost 8 years ago

Is it possible to have two different editions on the same computer, I would be happy to have 1.9 beta as long as it doesn't stop me from using 1.8 (with different project files) in case some serious issue shows up.

#5 Updated by Regis Haubourg almost 8 years ago

You can use --configpath option described in the manual. In master , preferences and .qgis profile can be moved where you want, so that the two versions won't interfer

#6 Updated by Patrick Dunford almost 8 years ago

Thanks for that. Is there somewhere I can find out about the new features in 1.9, when do you expect the release?

#7 Updated by Alexander Bruy over 6 years ago

  • Status changed from Open to Closed

Works fine for me. Please reopen if necessary

Also available in: Atom PDF