Bug report #6381

MSSQL tables - Primary Key with multiple columns Problem

Added by Maria G Saavedra almost 7 years ago. Updated 12 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15641

Description

Adding a table with multiple columns as primary key, QGIS is not recognizing both primary key columns, only the first one, and when we edit a information/geometry or search in the attributes table, the data that is shown is incorrect, even we had updated information by mistake because of this.

MSSQL Server Standard Edition 2008 R2
QGIS 1.8.0-Lisboa
Windows 7 64 bits


Related issues

Duplicated by QGIS Application - Bug report #6387: MSSQL tables - Primary Key with multiple columns Problem Rejected 2012-09-20

History

#1 Updated by Pirmin Kalberer almost 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#2 Updated by Nathan Woodrow almost 7 years ago

  • Assignee set to Tamas Szekeres

#3 Updated by Nathan Woodrow over 5 years ago

  • OS version deleted (Windows 7 - 64bits)
  • Target version changed from Version 2.0.0 to Future Release - Nice to have
  • Operating System deleted (Windows)

#4 Updated by Jürgen Fischer about 3 years ago

  • Assignee deleted (Tamas Szekeres)

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please test with a recent QGIS release (2.18 or 3), if the issue/request is still valid change the affected version accordingly, if is fixed/implemented then close the ticket. Thanks!

#7 Updated by Nyall Dawson 12 months ago

  • Status changed from Feedback to Closed
  • Description updated (diff)

Closing due to lack of feedback

Also available in: Atom PDF