Bug report #6387

MSSQL tables - Primary Key with multiple columns Problem

Added by Maria G Saavedra almost 7 years ago. Updated almost 7 years ago.

Status:Rejected
Priority:Normal
Assignee:Tamas Szekeres
Category:Data Provider/MSSQL
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15645

Description

Adding a table with multiple columns as primary key, QGIS is not recognizing both primary key columns, only the first one, and when we edit a information/geometry or search in the attributes table, the data that is shown is incorrect, even we had updated information by mistake because of this.

MSSQL Server Standard Edition 2008 R2
QGIS 1.8.0-Lisboa
Windows 7 64 bits


Related issues

Duplicates QGIS Application - Bug report #6381: MSSQL tables - Primary Key with multiple columns Problem Closed 2012-09-20

History

#1 Updated by Jürgen Fischer almost 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Rejected

duplicate of #6381

Also available in: Atom PDF