Bug report #5848

Different icons for QGIS and QGIS Browser

Added by Alexander Bruy over 8 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Larry Shaffer
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15318

Description

Currently both QGIS and QGIS Browser share same icon, this is a bit confusing for users. It will be better to use different icon for QGIS Browser. Here is my attempt to create such icon.

P.S. not sure how to classify this — as bug or as feature. Please correct, if I'm wrong

browser_ico_32.png (2.22 KB) Alexander Bruy, 2012-11-03 12:35 PM

qgisb.png (23.3 KB) Larry Shaffer, 2012-11-03 12:47 PM

qgis_browser_icon_prototype_v1.svg (19.3 KB) Andreas Neumann, 2014-02-17 05:12 AM

icon_prototype_v14_magnifier.svg (36.4 KB) João Gaspar, 2014-02-18 09:54 AM

qgis_browser_icon_prototype_v12.svg (23.4 KB) zirneklitis -, 2014-06-12 06:26 PM

icons.tar.xz (423 KB) zirneklitis -, 2014-06-13 01:13 AM

icon_prototype_v15_magnifier.png (41.3 KB) João Gaspar, 2014-10-02 01:50 PM

qgis_globe_draft1.png (113 KB) Anita Graser, 2015-05-22 12:02 PM

qgis_globe_draft1.svg (39.3 KB) Anita Graser, 2015-05-22 12:02 PM

qgis_browser.ico (87.9 KB) Anita Graser, 2015-05-24 04:53 AM


Related issues

Duplicated by QGIS Application - Feature request #6559: The Icons for the QGIS Browser & Application need to be d... Closed 2012-10-22

History

#1 Updated by Paolo Cavallini about 8 years ago

  • Target version set to Version 2.0.0

#2 Updated by Alexander Bruy almost 8 years ago

Here is sample icon for QGIS Browser.

#3 Updated by Larry Shaffer almost 8 years ago

  • File qgisb.png added
  • Status changed from Open to Feedback

Hi Alexander,

Here is a version I made for when we created an alias to the embedded browser within the main QGIS.app bundle for Mac OS X (3c1c229). Attached here as a PNG, exported from the Mac .icns file.

#4 Updated by Giovanni Manghi over 7 years ago

  • Assignee set to Larry Shaffer

Larry Shaffer wrote:

Hi Alexander,

Here is a version I made for when we created an alias to the embedded browser within the main QGIS.app bundle for Mac OS X (3c1c229). Attached here as a PNG, exported from the Mac .icns file.

Hi Larry,
could you please commit this icon? Especially on Windows having two identical icons on the desktop is very confusing for many users.

#5 Updated by Alexander Bruy over 6 years ago

  • Category set to 95

#6 Updated by Paolo Cavallini over 6 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Tag set to easy

See:

https://drive.google.com/folderview?id=0B98hU-Ebn7VvX2lGTFRvWkdiX28&usp=sharing

IMHO this should changed, as it is quite confusing for users.

#7 Updated by Jürgen Fischer over 6 years ago

Paolo Cavallini wrote:

IMHO this should changed, as it is quite confusing for users.

and which one? two here, a couple of others there...

#8 Updated by Paolo Cavallini over 6 years ago

My vote is for qgis_browser_icon_prototype_v6.svg

But anyone is ok for me.

#9 Updated by Andreas Neumann over 6 years ago

My vote is for the version qgis_browser_icon_prototype_v1.svg - but with a change that the folders are in blue instead of yellow (like in OSX or KDE). This way one can better distinguish the folders from the QGIS icon.

I uploaded a modified version at this ticket with the blue folders.

#10 Updated by João Gaspar over 6 years ago

Andreas, my suggestion:

If we use the icon v1 prototype we need to pick a color for the folders that is neutral for all OS.

But for me the main goal is definitely the use of a different icon for browser.

#11 Updated by Anita Graser over 6 years ago

I don't think v1 is the best option. In my opinion, the difference between the desktop and browser icon should be more easily visible. My suggestion would be v6 or v9.

Is this the correct location in the repo to put he new browser icon: https://github.com/qgis/QGIS/tree/master/images/iconshttps://github.com/qgis/QGIS/tree/master/images/icons?

#12 Updated by Larry Shaffer over 6 years ago

I agree with Anita, the icon needs to be more discernible from desktop app icon, especially when at 24 x 24px. However, I think the folder graphic should be avoided, since it will always clash with some OS's folder icons.

I used a magnifying glass as an icon stamp (see above). I suggest using that or a similar concept for a stamp, or having a 'browser'-concept background, and one that is more 3D-looking than the current choices.

#13 Updated by João Gaspar over 6 years ago

Icon based on magnifier icon of Larry.

#14 Updated by zirneklitis - over 6 years ago

Keeping in mind the size of icons (16×16, 24×24, .. , 512×512) I modified the qgis_browser_icon_prototype_v2.svg

#15 Updated by zirneklitis - over 6 years ago

The old QGIS symbol is good for creating QGIS browser icon as it is much thinner then the present one. Take a look at the set of icons.

#16 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#18 Updated by João Gaspar almost 6 years ago

Hi guys, i add more icons for .qml, .qgs, .qpt see in:

https://github.com/jonnyforestGIS/others_prototype_files_QGIS

The mailing discussion is over here:
http://osgeo-org.1560.x6.nabble.com/Qgis-files-and-related-icons-td5163236.html:

Regards,
João

#19 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Open

#20 Updated by Anita Graser over 5 years ago

We discussed this shortly at the dev meeting. The browser icon should be significantly different to be easily distinguished from the desktop icon. Therefore, small addons in the corner of the original Q don't work.

I suggest the following icon which uses the QGIS colors but the color focus is clearly on the darker green rather than the yellow-green of the Q.

It would be great if we could decide to have a new icon in 2.10. Jürgen has already prepared the repo and we just need to replace https://github.com/qgis/QGIS/blob/master/src/browser/browser.ico

#21 Updated by Anita Graser over 5 years ago

Here's the ico

#22 Updated by Anita Graser over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Target version changed from Future Release - Lower Priority to Version 2.10

The icon is in now. Thanks Jürgen for adding!

#23 Updated by Jürgen Fischer over 5 years ago

(accidently) committed in 83899182

#24 Updated by Larry Shaffer over 5 years ago

Hi,

If this new icon is agreed upon, I will convert it for Mac icon format and place it at (qgisb.icns):

https://github.com/qgis/QGIS/blob/master/images/icons/mac/browser/

#25 Updated by Andreas Neumann over 5 years ago

Would it be possible to also backport this to the 2.8 branch? Esp. for people who installed several versions at once, it helps a lot to better distinguish browser from desktop. Also, it should be fairly save to backport this ;-)

Also available in: Atom PDF