Feature request #5656

Print Composer Rulers + Guides

Added by Antonio Locandro about 5 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

Can we add guides and ruler to print composer? This would be great when creating a map for print. One should be able to select inches, centimetres or points as well as the smallest division for rulers plus the ability to hide or show both rulers and guides. Added a screenshot of what the rulers and guides could look like

PRINT_COMPOSER_RULERS_AND_GUIDES.png - Mockup for Rulers and Guides (987 KB) Antonio Locandro, 05/28/2012 10:19 AM

Associated revisions

Revision 097a1954
Added by Nyall Dawson over 3 years ago

[composer] Improve appearance of rulers, add small tick marks to ruler (fix #5656)

History

#1 Updated by Paolo Cavallini about 5 years ago

Snapping to grid is available already.

#2 Updated by Giovanni Manghi about 5 years ago

  • Category set to 33
  • Status changed from Open to Feedback

#3 Updated by Antonio Locandro about 5 years ago

Yeah, not really as useful since the Guides are for "Guiding", plus I just set my units to inch and the snap to grid continues to work on mm. Pretty much the ruler and guides are standard to most CAD/GIS/Graphic Design. You can change the priority to Low if you wish, but I would consider this an enhancement

#4 Updated by Antonio Locandro about 5 years ago

Plus try to create a Layout (Print Composer) with exact dimensions, a header line at 0.5 inch a footer line at 10.5 inch the data frame ('canvas') to start at 1 inch for left margin and end at 10.5 inch for right margin. I would bet that is time consuming changing the grid spacing every time to achieve that result.

#5 Updated by Nathan Woodrow about 5 years ago

I agree this would be a cool feature.

#6 Updated by Paolo Cavallini almost 5 years ago

  • Target version set to Version 2.0.0

#7 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#8 Updated by Antonio Locandro about 4 years ago

So I have tried the guides and rulers added on master and they are an incredible addition to QGIS, its getting closer for me to recommend it for print production I still would like to see the possibility to change the units from mm to inches and points, plus subdivisions, and the option to turn guides on/off to see hoy the Layout looks without the guides in the middle.

Thanks a lot to the developer of this little piece of code, thanks him on my behalf

#9 Updated by Nyall Dawson over 3 years ago

  • Status changed from Feedback to In Progress

Everything here has been covered so far except print units in inches/points (duplicate of #7959 and #7367) and subdivisions in the composer ruler. I'm working on that feature now.

#10 Updated by Nyall Dawson over 3 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF