Bug report #5407

MSSQL Server - tables are invalid layers for Build 116

Added by Carlos da Ponte over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:Tamas Szekeres
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15073

Description

All tables imported fine using build 115. Updated to build 116, tried to import the same layers and all (~20 layers) yield error msg - "dbname='XX' host=XXX,1433 user='synergy' password='XXXXXX' srid=3005 type=POINT table="dbo"."site" (geolocation) sql= is an invalid layer and cannot be loaded"


Related issues

Related to QGIS Application - Bug report #5409: Spatialite support broken since commit:4d6cc6d Closed 2012-04-18
Related to QGIS Application - Bug report #5410: Copy constructor of QgsDataSourceURI does not work Closed 2012-04-18

Associated revisions

Revision e5d97f53
Added by Jürgen Fischer over 9 years ago

Revert d7e8ae18 and d637c677c (fixes #5407, #5409 and #5410)

History

#1 Updated by Nathan Woodrow over 9 years ago

This is a problem with the host name getting passed to the provider. Tamas is working on a fix.

As a workaround you can create a ODBC DSN and use it. It still workes correctly with a DSN.

#2 Updated by Nathan Woodrow over 9 years ago

  • Assignee set to Tamas Szekeres

#3 Updated by Jürgen Fischer over 9 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF