Bug report #5409

Spatialite support broken since commit:4d6cc6d

Added by Gerhard Spieles over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Win Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15074

Description

Trying to load a spatialite layer, Qgis reports:

dbname='C:/pojekte/testsqlite/testqgisspatialite.sqlite' table="testbeitragsflaechen" (Geometry) sql= ist ein ungültiger Layer - nicht geladen

20120418_qgis_master_ver_191a229_spatialite_ok.jpg (227 KB) Gerhard Spieles, 2012-04-18 01:54 PM

20120418_qgis_master_ver_4d6cc6d_spatialite_broken.jpg (182 KB) Gerhard Spieles, 2012-04-18 01:54 PM

dbqgiscreated.sqlite (3.54 MB) Gerhard Spieles, 2012-04-18 01:54 PM


Related issues

Related to QGIS Application - Bug report #5407: MSSQL Server - tables are invalid layers for Build 116 Closed 2012-04-18
Related to QGIS Application - Bug report #5410: Copy constructor of QgsDataSourceURI does not work Closed 2012-04-18

Associated revisions

Revision e5d97f53
Added by Jürgen Fischer over 9 years ago

Revert d7e8ae18 and d637c677c (fixes #5407, #5409 and #5410)

History

#1 Updated by Tim Sutton over 9 years ago

Could you supply a small example of a spatialite lite layer that fails in this way - preferably one with data that we can redistribute so that it can be used as a unit test.

Thanks

Tim

#2 Updated by Jürgen Fischer over 9 years ago

  • Subject changed from Spatiallite Layer is not supported in qgis master since QGIS-Codeversion 4d6cc6d to Spatialite support broken since commit:4d6cc6d

#3 Updated by Gerhard Spieles over 9 years ago

Hello,

attached screenshots of QGIS and teh related sqlite db.
QGIS-dev is installed from OSGeo4W

#4 Updated by Jürgen Fischer over 9 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF