Bug report #5410

Copy constructor of QgsDataSourceURI does not work

Added by Tamas Szekeres over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15075

Description

The copy constructor currently copy the mParams attribute, but doesn't copy the attributes initialized by the QString constructor.
For this reason the following code does not work correctly:

QgsDataSourceURI uri = QgsDataSourceURI( srcUriString );

Problem was introduced by d7e8ae18c725d356ecc02f27d5a94ae3d4462537

This problem breaks the MSSQL provider and probably some others as well


Related issues

Related to QGIS Application - Bug report #5407: MSSQL Server - tables are invalid layers for Build 116 Closed 2012-04-18
Related to QGIS Application - Bug report #5409: Spatialite support broken since commit:4d6cc6d Closed 2012-04-18

History

#1 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

reverted in e5d97f53

Also available in: Atom PDF