Bug report #4687

memory vector layer does not show nor export attributes

Added by Alessandro Pasotti over 8 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:14573

Description

See attached file, copy/paste it into python console on an empty project.
Open attributes table.

If you enable editing then the attributes are shown.
After enabling editing, the attributes are subsequently shown even if you disable editing.

Confirmed by me and alexbruy.

qgis_memory_layer_test.py Magnifier - test case (868 Bytes) Alessandro Pasotti, 2011-12-21 03:16 AM


Related issues

Related to QGIS Application - Bug report #5633: Memory Layers Attribute Table do not display the data Closed 2012-05-24

History

#1 Updated by Richard Duivenvoorde over 8 years ago

please have a look a this email thread:

http://osgeo-org.1803224.n2.nabble.com/Add-attributes-to-memory-provider-with-python-td6073149.html

when you actually call layer.updateFieldMap() the fields are visible.

(has to be fixed anyway....)

#2 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version set to Version 2.0.0
  • Affected QGIS version set to master

#3 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#4 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#5 Updated by Alexander Bruy about 3 years ago

  • Description updated (diff)

#6 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF