Bug report #4419

Improve random colour ramps

Added by Paolo Cavallini almost 8 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14351

Description

The random colour ramps are generally ugly, and often colours are repeated

45.png (155 KB) Giovanni Manghi, 2013-06-07 06:57 AM

colour_ramp.png (97.6 KB) Paolo Cavallini, 2013-07-12 03:51 AM

26.png (171 KB) Giovanni Manghi, 2013-11-24 02:25 AM

27.png (45.9 KB) Giovanni Manghi, 2013-11-24 02:25 AM

Associated revisions

Revision f0120656
Added by Nyall Dawson over 6 years ago

Fix #4419, improve random color ramp appearance and generate colors with better chance of uniqueness

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#2 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Nyall Dawson over 6 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 6 years ago

Nyall Dawson wrote:

Fixed in changeset f01206565847655d1caee64d342d999988c66491.

Hi Nyall, good afternoon,

how the fix is supposed to work? I created a 99 color random color ramp, and by default it looks much better than before, but when applied it is not random at all, see attached image. Thanks!

#6 Updated by Giovanni Manghi over 6 years ago

Nyall Dawson wrote:

Fixed in changeset f01206565847655d1caee64d342d999988c66491.

bump, see #4419-5

#7 Updated by Paolo Cavallini about 6 years ago

  • Status changed from Closed to Reopened

#8 Updated by Paolo Cavallini about 6 years ago

Apparently the ramp is created well, but is not applied, and the resulting vector or raster is blank.

#9 Updated by Nathan Woodrow about 6 years ago

Do you have a image. I don't have any issues with colour ramps here.

#10 Updated by Giovanni Manghi about 6 years ago

Nathan Woodrow wrote:

Do you have a image. I don't have any issues with colour ramps here.

#11 Updated by Paolo Cavallini about 6 years ago

Apparently it is misclassified, see attached.

#12 Updated by Giovanni Manghi about 6 years ago

Paolo Cavallini wrote:

Apparently it is misclassified, see attached.

confirmed, but it works if you use mode "equal interval".

it seems to affect only the random color ramps, other manually created ramps seems not affected.

#13 Updated by Nyall Dawson almost 6 years ago

  • Status changed from Reopened to Closed

#14 Updated by Giovanni Manghi almost 6 years ago

Nyall Dawson wrote:

Fixed in changeset f01206565847655d1caee64d342d999988c66491.

Hi Nyall,

I just tested master and things seems better but not as good with the old "random" symbology we had in the old symbology engine. See the attached images.

At this point I don't think that makes a lot of sense re-opening this ticket, what I suggest is to open a feature request to add a new renderer ("random") eventually using ideas from the old symbology engine or plugins like http://plugins.qgis.org/plugins/mapcoloring/

Also available in: Atom PDF