Bug report #4108

Switching from new to old polygon symbology then back again ends up with polyline symbology

Added by Alister Hood about 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:14090

Description

Using new symbology, style a polygon layer with only an "Outline: ..." style.
Switch the layer to old symbology and do not apply the changes.
Switch back to new symbology - the dialogue now gives the options for a polyline layer, not a polygon layer!
Click "Apply" - the layer will now be invisible!

BTW, is the "outline" style really necessary? Can't you achieve the same result with the simple "fill" style?

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version set to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Nyall Dawson over 5 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

No longer relevant

Also available in: Atom PDF